summaryrefslogtreecommitdiff
path: root/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-31 21:13:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-31 21:13:59 +0100
commitae1bf373db295b495e1f685d116e3411bf10df0b (patch)
treec932e36e049f06d2da6c60316ffb2aaa27e11eb4 /dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild
parent2cfae1fadeca2d0c51a301318c96c2cf5073eb6f (diff)
gentoo auto-resync : 31:07:2022 - 21:13:58
Diffstat (limited to 'dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild')
-rw-r--r--dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild b/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild
new file mode 100644
index 000000000000..96a8efe53f09
--- /dev/null
+++ b/dev-python/allpairspy/allpairspy-2.5.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pairwise test combinations generator"
+HOMEPAGE="https://github.com/thombashi/allpairspy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+
+distutils_enable_tests pytest