summaryrefslogtreecommitdiff
path: root/dev-python/alembic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/alembic
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest2
-rw-r--r--dev-python/alembic/alembic-1.7.6.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index a9ccce3abb65..b4284d9820e5 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,3 +1,5 @@
DIST alembic-1.7.5.tar.gz 1229596 BLAKE2B dbedcc43f60b2b28adc17b1c0c753b22993127acd5aab04bbf4a47920e11894498618d353eb544b48c0c5698d7cf6f96fba39a98df723a611810e71e24809b0e SHA512 4223116c3610f3196335c1fb2032a9a236c3e6ec4e4ca5cb85ccc3667d614e77d51d9fee1ee0173a32451198929428c1fcf39afd90b6df32584b076e0a4ab1a4
+DIST alembic-1.7.6.tar.gz 1235649 BLAKE2B 5e12cf09927c7851ad5c95b7047865eec6ca01d3ce94045be3601855370e1cce8371d16ee4141a953a8ea0ffaafaa68c08499416283c7996b086b7b5967c8790 SHA512 dca97722ac70654dfa23d673b776d064af13bf1e59219131d7716d7ce183508361bad713d7d0986c8a56dd66c58a59fafc1c3b3ef80507eaf6368e48f9c1a059
EBUILD alembic-1.7.5.ebuild 884 BLAKE2B f3d62f2ebf0e5c87be25aa30761108b2f0210ae2508026b354c9431ea73ff51f0878c38ca3f1a6a38632834e83b49c9bed94a277d2646b7d684d0fb1c9adc93b SHA512 eec90de5278a58c0c1e42c60b36a6074d738cf9b6dde86b22e4a8edf56ea748491e4b1af4d7f14b9654ce4ff63e3b36db2de743f237ac7edfb3591aabb254027
+EBUILD alembic-1.7.6.ebuild 918 BLAKE2B 8104d86b61ca37a9409fda606f5acb3d89802ac23b0b196625bed67b0541f3d5baf588045613da596dd3b2edf02f17f22a9bfa566bd016ee100d54af3f0b1a43 SHA512 faa7f3c6bd8c25070affd7930e5861fb706e54c77cf153f3eab0524f220ad83d2eebf99929f9681fb90967093afc6203f5363f839cbf603e756e1ef1feb987ef
MISC metadata.xml 516 BLAKE2B 08b11ebed2913b00e0a8c0044a50e3ca7bc0e51fcad180725c90445227fed1aed58ed89b4bed58ef5c050c3eee3c19da33aabce5cd1f7835f4b560e67ccc7744 SHA512 b4afb6af57562e6065f03db71da0dbdfc9c4337e54cbaddfa257ee7bad48dbeecfaccd765901bf65279e34cf96be3975f983017858904716a36bf8c18f33db79
diff --git a/dev-python/alembic/alembic-1.7.6.ebuild b/dev-python/alembic/alembic-1.7.6.ebuild
new file mode 100644
index 000000000000..9e34986e5995
--- /dev/null
+++ b/dev-python/alembic/alembic-1.7.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://github.com/sqlalchemy/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ >=dev-python/sqlalchemy-1.1.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ dev-python/importlib_resources[${PYTHON_USEDEP}]
+ ' pypy3 python3_8)
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+ distutils-r1_python_install_all
+}