summaryrefslogtreecommitdiff
path: root/dev-python/alembic
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/alembic
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/Manifest2
-rw-r--r--dev-python/alembic/alembic-1.0.8.ebuild48
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 8537ffccde79..211af40619ed 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,5 +1,3 @@
-DIST alembic-1.0.8.tar.gz 1030713 BLAKE2B 67cb80ed064e99f27e41a7ae2e42231794c177f96b95e2c3409a0ebc26e5323665147b2721efcc4a4d8ee2a71ada76408187f39ff5ad3745de64ed31f87d2895 SHA512 7a2ab63c6a823a32f45cd8ff5b763671806a8fa3d2b31e09c2051bdf92784fdafea1e3be217d84885d92eaf550e223ef77fd6fd387d35a5882d60ebcf042d835
DIST alembic-1.4.2.tar.gz 1092045 BLAKE2B 5f4001a756aacbb4db509669bc0d4d7c59c38e2983c433283243efa97bf28a22e38bcfd28a4bc72573e8ab78d6590e78f4e12a5b9dd08b60cf5a84520b955056 SHA512 82bdfe442c19033aa2b802ec49edd13ed265c00a2b5a048490a83ffa8e53587c56a90b64d554e746a9189923419c528482cb7a7c950c210e0de47b32fa7c270e
-EBUILD alembic-1.0.8.ebuild 1412 BLAKE2B e8dc987cb0e1ec70a454d43828c8bd4c15d028fd6d63dd4ca6f8ab15f11b5b208b2b90d867ce95843c9dcad4b5e0d82b954c4d73e80a07e56c8dab68ec00e03c SHA512 7346c12c90fc7617de8d0c015e77f9856975b0d127c11eda15ac63732f07986d4c3030db37c3420e2caefcd7dfa831b3d5b2e6e0259caef046b565c88308f460
EBUILD alembic-1.4.2.ebuild 1191 BLAKE2B 9f76369659af2bb4e6fa26e2016aa689f0f33e2e24f7bd1ef2983f577c8615010231d6c5c1ae53d1c2e43b889022bb1c18f782ca0b7a1e750c02f2f36097cd29 SHA512 ea7ffcca42d4863e24a5300c3b84068c8dfeff2f6805dc7d062a33d90a71657f54f6a4fa7aa4bfc15b98a2202091f012bb33084c13404631a066c0cf81c9b21e
MISC metadata.xml 379 BLAKE2B 8fcdef99cd9d57757692cf72b6f43bf874b7657899197d754ad81866f77d0a48d0fdaf168eeb37ad29ec975ddd7533be90f1e9926de9faf1bb56c3ad4e1d7513 SHA512 809c3f1585e85726feefc7f8493ec83ee31a9f7aa99aacf82026742f278726ad960a63b40c701a1a2453d46fd64d8245b83f2bd7511b5cc077c44bc62dda3e83
diff --git a/dev-python/alembic/alembic-1.0.8.ebuild b/dev-python/alembic/alembic-1.0.8.ebuild
deleted file mode 100644
index c19da229c3ab..000000000000
--- a/dev-python/alembic/alembic-1.0.8.ebuild
+++ /dev/null
@@ -1,48 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} )
-inherit distutils-r1
-
-DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
-HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 x86"
-IUSE="test doc"
-RESTRICT="!test? ( test )"
-
-# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
-# because it shatters the testsuite. If 'someone' cares to adhere to correct form
-# and edit to -0.7.3, feel free, and then pick up the pieces.
-RDEPEND=">=dev-python/sqlalchemy-0.9.0[${PYTHON_USEDEP}]
- dev-python/mako[${PYTHON_USEDEP}]
- >=dev-python/python-editor-0.3[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}] )"
-# For test phase
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # suite passes all if run from source. The residual fail & error are quite erroneous
- rm tests/test_script_consumption.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/. )
-
- distutils-r1_python_install_all
-}