summaryrefslogtreecommitdiff
path: root/dev-python/alembic/alembic-1.11.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-07 15:42:35 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-07 15:42:35 +0100
commita693a49d235bea057923bcbc2ee6a40cce4bb060 (patch)
tree7b927ab3d5df3dce15e8c6a727db1831137f9a00 /dev-python/alembic/alembic-1.11.1.ebuild
parentbba809b22a050e394e6ce550572ee7f6c6e02a6e (diff)
gentoo auto-resync : 07:06:2023 - 15:42:35
Diffstat (limited to 'dev-python/alembic/alembic-1.11.1.ebuild')
-rw-r--r--dev-python/alembic/alembic-1.11.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/alembic/alembic-1.11.1.ebuild b/dev-python/alembic/alembic-1.11.1.ebuild
index 8abd48cc9bb7..0fb0d2348c60 100644
--- a/dev-python/alembic/alembic-1.11.1.ebuild
+++ b/dev-python/alembic/alembic-1.11.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 pypi
@@ -29,6 +29,12 @@ RDEPEND="
distutils_enable_tests pytest
+python_test() {
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
python_install_all() {
use doc && local HTML_DOCS=( docs/. )
distutils-r1_python_install_all