summaryrefslogtreecommitdiff
path: root/dev-python/aiounittest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-08 10:24:46 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-08 10:24:46 +0000
commit9263a8dda30106335f556e7f5936f5607db6f92c (patch)
tree59614d42ee7ac6187fd0c542956f2aa89c39f6e9 /dev-python/aiounittest
parentd8ae0501eb6c157339ede48ca34513d27470e1dc (diff)
gentoo auto-resync : 08:11:2023 - 10:24:46
Diffstat (limited to 'dev-python/aiounittest')
-rw-r--r--dev-python/aiounittest/Manifest3
-rw-r--r--dev-python/aiounittest/aiounittest-1.4.2.ebuild29
-rw-r--r--dev-python/aiounittest/metadata.xml12
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/aiounittest/Manifest b/dev-python/aiounittest/Manifest
new file mode 100644
index 000000000000..f13f3dd7a21f
--- /dev/null
+++ b/dev-python/aiounittest/Manifest
@@ -0,0 +1,3 @@
+DIST aiounittest-1.4.2.gh.tar.gz 15791 BLAKE2B 7784bbf94de2b8520baef66a0b4929267942d233cc782f35677ea05b02e3d48901ba90cf9630b76bd300708ebbe59dd9d78c299422182c06940749bc2b378b45 SHA512 358b7c412f90eb7afc7ed7058e8e2d4426a6c57379d341d997658859ba6054a9a1337d0b05e63a825e28023f02550bd72d65bdb3feab4503c763c98f8c0d19c6
+EBUILD aiounittest-1.4.2.ebuild 569 BLAKE2B 7c4bb7dd377a2b520c2f21d3f247659ac4acff2f1661dc501d0392523ec3c3fbc13cca039facabc81fc19bc6a4f23d65b9d00c4ccc35f3648e86ac0f0125a7b9 SHA512 3cd83e835fc36ae60e8b2c23493b6dddd983419977f5cc42af1f81c3011eadd83cb2e090ea5113d79e2e7a229cfd6f5752c3516b1460b9533637ccec25c59f91
+MISC metadata.xml 377 BLAKE2B 9197f2ced7dab8b68159fb9b1963d5dc25d312bb2d333f1e119fa57d0e7d5054bda3ffc79244d2cf96a5ae830af506215499f12dabfd688d8c344b457ac2f7d3 SHA512 71d4bb2c9b4e46a0d56ee56c5afb20f9d726ff0a8f35647df4096f83f77062ab33aa04958dd6d82a0a9276642a326b0790ef04012e8574b21fa2ac85f9b77354
diff --git a/dev-python/aiounittest/aiounittest-1.4.2.ebuild b/dev-python/aiounittest/aiounittest-1.4.2.ebuild
new file mode 100644
index 000000000000..6d54d3712879
--- /dev/null
+++ b/dev-python/aiounittest/aiounittest-1.4.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Test asyncio code more easily"
+HOMEPAGE="
+ https://github.com/kwarunek/aiounittest/
+ https://pypi.org/project/aiounittest/
+"
+SRC_URI="
+ https://github.com/kwarunek/aiounittest/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~x86"
+
+RDEPEND="
+ dev-python/wrapt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/aiounittest/metadata.xml b/dev-python/aiounittest/metadata.xml
new file mode 100644
index 000000000000..cdd7b4c658c7
--- /dev/null
+++ b/dev-python/aiounittest/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">kwarunek/aiounittest</remote-id>
+ <remote-id type="pypi">aiounittest</remote-id>
+ </upstream>
+</pkgmetadata>