summaryrefslogtreecommitdiff
path: root/dev-python/aiotest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-05 18:44:56 +0000
commit29aabba0ea759c6a2864ff5631735b67ee38e5e0 (patch)
treeab466b4dfa7abecb401b2f8039d08af4689306bb /dev-python/aiotest
parentd42200bec37eef2a7478d88988ff00addd0a9202 (diff)
gentoo resync : 05.02.2020
Diffstat (limited to 'dev-python/aiotest')
-rw-r--r--dev-python/aiotest/Manifest2
-rw-r--r--dev-python/aiotest/aiotest-0.3.ebuild9
2 files changed, 3 insertions, 8 deletions
diff --git a/dev-python/aiotest/Manifest b/dev-python/aiotest/Manifest
index f522b9ec9262..0280711ea8bd 100644
--- a/dev-python/aiotest/Manifest
+++ b/dev-python/aiotest/Manifest
@@ -1,3 +1,3 @@
DIST aiotest-0.3.tar.gz 10146 BLAKE2B 730da4dcdf50d0cc6262f8ec07c260981440734b672be6c997dd7f98afa7b71300f0461d5b3ebfc052995327b1f9f9429a1e84658b100dc689f633e8d7db5071 SHA512 6af65e283dfae1ff0f09fb09498f1a5be971daef4907c5079acc1c7ad353f4aa415e03f3fb18d9fac28c54abe35c9db917584082a56b4b43cd80cbf5fa689d59
-EBUILD aiotest-0.3.ebuild 788 BLAKE2B 243b931a7e5eb8d85815c3272bf2c1b0fd746d0b181dd38dd36810c8a4213eba1a8624495e5e69c7048923b853dffda91de25fd261af2be1a43049822145c1a6 SHA512 227f2f861dd175c708f68093bf18e86b4a1d6f655d29ab354553468f9fc88cb6082e6fe78c0ade767d406a431ef19d7e4df3da28c3689a3ccc329b829c90a09c
+EBUILD aiotest-0.3.ebuild 545 BLAKE2B a3803be390bab54d3ef87985a153eb10cbff2f9460377aa0c0bf6abf78d7379a3fb09ef1823f1e8b63cc4510295c3d5ce599e201621b953739c5853c0c8b38ae SHA512 c1801e42a3b294cf8627443a0dd634f94ebb9fb6c4ef0a1a9f671f835ce6f44206c5fd1d674c178a151d3a23f615e6ff2ec46b22ea53550480fc0abf9ad43db4
MISC metadata.xml 344 BLAKE2B c1f17b0db31bed7998b4d75c436520f05722062eb60f64df7fbb3b9d75d324d77f7e6f96cd3dcf2baabd6a0c9e11219b87c13f354f0e04239032dd3796ee7bc6 SHA512 da7c8a88e3043b5148eed4f1de62acd094f7e0f791cbb7d9707a97ba5fc85a1833c9754ab3beac904ccfca500b20196999b1381a8f5bdafb5375f2c9b7689819
diff --git a/dev-python/aiotest/aiotest-0.3.ebuild b/dev-python/aiotest/aiotest-0.3.ebuild
index f17915b2cd3a..c04392458906 100644
--- a/dev-python/aiotest/aiotest-0.3.ebuild
+++ b/dev-python/aiotest/aiotest-0.3.ebuild
@@ -3,7 +3,7 @@
EAPI=6
-PYTHON_COMPAT=( python2_7 python3_6 )
+PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
DESCRIPTION="Test suite for an implementation of asyncio (PEP 3156)"
@@ -15,14 +15,9 @@ SLOT="0"
KEYWORDS="amd64 ~arm64 x86"
IUSE=""
-RDEPEND="
- $(python_gen_cond_dep 'dev-python/trollius[${PYTHON_USEDEP}]' python2_7)
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7)"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]"
python_test() {
- local suite
- python_is_python3 && suite=asyncio || suite=trollius
- "${PYTHON}" "test_${suite}.py" || die "Tests fail with ${EPYHON} (${suite})"
+ "${PYTHON}" "test_asyncio.py" || die "Tests fail with ${EPYTHON}"
}