summaryrefslogtreecommitdiff
path: root/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-31 21:02:55 +0000
commitd36c5f9e59f92a021c987989cd79d44460e0da42 (patch)
tree2504c88d1f287ac3a71ebc56e5d19f34a2c1b9a4 /dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
parente860dfa5acdb67f8e2b8938b005dbaaaaf2c984a (diff)
gentoo auto-resync : 31:01:2023 - 21:02:55
Diffstat (limited to 'dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild')
-rw-r--r--dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild b/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
new file mode 100644
index 000000000000..478599928eee
--- /dev/null
+++ b/dev-python/aiorpcX/aiorpcX-0.22.1-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Generic async RPC implementation, including JSON-RPC"
+HOMEPAGE="
+ https://github.com/kyuupichan/aiorpcX/
+ https://pypi.org/project/aiorpcX/
+"
+SRC_URI="
+ https://github.com/kyuupichan/aiorpcX/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/uvloop[${PYTHON_USEDEP}]
+ dev-python/websockets[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # require Internet
+ tests/test_socks.py::TestSOCKSProxy::test_create_connection_resolve_good
+)