summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/aiohttp
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/aiohttp')
-rw-r--r--dev-python/aiohttp/Manifest2
-rw-r--r--dev-python/aiohttp/aiohttp-3.6.2.ebuild132
2 files changed, 134 insertions, 0 deletions
diff --git a/dev-python/aiohttp/Manifest b/dev-python/aiohttp/Manifest
index 71745595e241..dacbeedb0cf1 100644
--- a/dev-python/aiohttp/Manifest
+++ b/dev-python/aiohttp/Manifest
@@ -1,3 +1,5 @@
DIST aiohttp-3.6.1.tar.gz 1113678 BLAKE2B cfdf1c650ec52c7b6423f7afd40060ccd1631a407f126bf64c2a353c51f09c31bae3912b8ce9397c0c8350a2e82a98724ae58335998d1ab08ae46a49abce0251 SHA512 4939b89d45abcd655ef212ff87f66a83882fb12dffb87d62ae57afcd9517725af61f46f9b7428112e2dcd72d3a4027524967461270ede34348ff3ead47d14c9b
+DIST aiohttp-3.6.2.tar.gz 1076923 BLAKE2B 14327a0bc5b5fffdf436a4c3525e4c25d80100aa464ed652316f7724c2bea6de4ace6c27e8a2a8cf9d895673ed63ed52e8c958ad611636e1e524a4e40efa4735 SHA512 49bd3089158c05ff6312420190ccd7fed95efb4a18b8aff7497d5507c71c692080d6949801edabdcd95379ca8e6614398408118d72ff1e782399e059e2cfc1a8
EBUILD aiohttp-3.6.1.ebuild 2179 BLAKE2B 956ae3f0a7439a67cda6bf44834fa28f5e2db93725fed02f4841f207f7dc3eac68e4a81a78df42e2f5cfebe53dbe1dc10d1012962e57fe8961dc4df985310e1a SHA512 c1e631f18adf1e21a4a901bb6074aee8dc4635a6cae6f2d74ec6e8a00e3f08d9bd494d92c85f3699035e6ed322c709a5f8e3ea2161c0447b3412b9f1e527b74d
+EBUILD aiohttp-3.6.2.ebuild 6174 BLAKE2B 12e6dc789736d88d28572609fc79f83488fe504a063b2ee0ab6007669d8eb2cb11416831340cb792a7f8db107c86360972c861fa4ad3540c37f24116a8bfef80 SHA512 603fa87993a484de17227f51aeb198199fcf0c8e5d202560da67dbd79ad76472ee200e83a4968a1aafa998285a2c756a90d9d8c2b16278020b31ebfd9799ddf2
MISC metadata.xml 489 BLAKE2B beb80da34848dfe7b81ed65d75923480644ecf42e2c5ce04a7f66f3e729651fdc6035054482aff966ec9f03cfbb812d3be0afd783af69e37f1002182e4885473 SHA512 d8c9e2edb8a57a3b6b02bb5314aef77dc266af6e80fd0300eb0652c59790232017d0062f5b7361b059c382d1c904f0f46cd0e672d1963e9595f3d4dc7514f182
diff --git a/dev-python/aiohttp/aiohttp-3.6.2.ebuild b/dev-python/aiohttp/aiohttp-3.6.2.ebuild
new file mode 100644
index 000000000000..fe8ce0270cf6
--- /dev/null
+++ b/dev-python/aiohttp/aiohttp-3.6.2.ebuild
@@ -0,0 +1,132 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="http client/server for asyncio"
+HOMEPAGE="https://pypi.org/project/aiohttp/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ >=dev-python/async_timeout-3.0.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.3.0[${PYTHON_USEDEP}]
+ dev-python/chardet[${PYTHON_USEDEP}]
+ >=dev-python/multidict-4.5.0[${PYTHON_USEDEP}]
+ >=dev-python/yarl-1.0[${PYTHON_USEDEP}]
+ dev-python/idna-ssl[${PYTHON_USEDEP}]
+"
+DEPEND="
+ dev-python/cython[${PYTHON_USEDEP}]
+ test? (
+ ${COMMON_DEPEND}
+ dev-python/async_generator[${PYTHON_USEDEP}]
+ dev-python/brotlipy[${PYTHON_USEDEP}]
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ www-servers/gunicorn[${PYTHON_USEDEP}]
+ >=dev-python/pytest-3.4.0[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+DOCS=( CHANGES.rst CONTRIBUTORS.txt README.rst )
+
+distutils_enable_sphinx docs \
+ '>=dev-python/alabaster-0.6.2' \
+ 'dev-python/sphinxcontrib-asyncio' \
+ 'dev-python/sphinxcontrib-blockdiag' \
+ 'dev-python/sphinxcontrib-newsfeed' \
+ 'dev-python/sphinxcontrib-spelling' \
+ 'dev-python/sphinx' \
+ 'dev-python/sphinx-aiohttp-theme'
+
+distutils_enable_tests pytest || die "Tests fail with ${EPYTHON}"
+
+python_prepare_all() {
+ sed -e 's|^async def test_aiohttp_request_coroutine(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_handle_keepalive_on_closed_connection(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_server_close_keepalive_connection(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_client_functional.py || die
+
+ sed -e 's|^async def test_request_tracing_exception(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_client_session.py || die
+
+ sed -e 's|^async def test_cleanup2(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_cleanup3(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close_abort_closed_transports(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close_cancels_cleanup_closed_handle(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close_cancels_cleanup_handle(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close_during_connect(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close_twice(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_close_with_acquired_connection(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_queued_operation_tracing(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_reuseconn_tracing(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_with_limit(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_with_limit_and_limit_per_host(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_with_limit_concurrent(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_with_no_limit_and_limit_per_host(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_connect_with_no_limits(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_get(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_get_expired(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_get_expired_ssl(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_limit_per_host_property(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_limit_per_host_property_default(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_limit_property(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_limit_property_default(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_acquired(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_acquired_closed(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_already_closed(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_close_do_not_delete_existing_connections(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_not_started(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_ssl_transport(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_waiter_first_available(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_waiter_no_available(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_waiter_no_limit(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_waiter_per_host(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_waiter_release_first(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_release_waiter_skip_done_waiter(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_tcp_connector_dns_throttle_requests_cancelled_when_close(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_tcp_connector_do_not_raise_connector_ssl_error(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_tcp_connector_uses_provided_local_addr(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_connector.py || die
+
+ sed -e 's|^ async def test_read_boundary_with_incomplete_chunk(| @pytest.mark.xfail\n\0|' \
+ -e 's|^ async def test_read_incomplete_chunk(| @pytest.mark.xfail\n\0|' \
+ -i tests/test_multipart.py || die
+
+ sed -e 's|^def test_aiohttp_plugin_async_fixture(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_pytest_plugin.py || die
+
+ sed -e 's|^async def test_mixed_middleware(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_new_style_middleware_class(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_new_style_middleware_method(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_old_style_middleware(|@pytest.mark.xfail\n\0|' \
+ -e 's|^async def test_old_style_middleware_class(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_web_middleware.py || die
+
+ sed -e 's|^async def test_client_disconnect(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_web_protocol.py || die
+
+ sed -e 's|^async def test_partially_applied_handler(|@pytest.mark.xfail\n\0|' \
+ -i tests/test_web_urldispatcher.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ pytest -vv "${S}/tests" || die "Tests fail with ${EPYTHON}"
+}