summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-08-02 19:14:55 +0100
commitb24bd25253fe093f722ab576d29fdc41d04cb1ee (patch)
tree0fcf2afd9f852c4d4c291cf8afaa2c244d598105 /dev-python/aiohttp-socks
parent121ed4eec41fbf03e1998d09eede1bf449da63b9 (diff)
gentoo resync : 02.08.2019
Diffstat (limited to 'dev-python/aiohttp-socks')
-rw-r--r--dev-python/aiohttp-socks/Manifest2
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild32
2 files changed, 25 insertions, 9 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index eeabff486e2f..09846c5a23d2 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1,3 +1,3 @@
DIST aiohttp-socks-0.2.2.tar.gz 1351798 BLAKE2B 40c9e033de523cad365e95051d48dee5fbd3d964e7b3864393c54d23394a5cfcfcb46cb9d78f25a6101bc97034c77c5a75aef94cfb962054c29bd804e387b0a9 SHA512 218c262cb3eab74166686614ab5a720c31d1ce886cfd655f296c930f648b1d94e909724346769a46b600b8f1bc8ddbc498ee75cd5854e409566a8ead6a7efdab
-EBUILD aiohttp-socks-0.2.2.ebuild 493 BLAKE2B 326b5fff1fa5847e6f08bf0e249e777f78268bd1a0487383c81c9c7a9b0be6ec795b99a8883a44636a48b28d88bfb3674326021e9ac7fa5d37497aad858a4dc9 SHA512 bc723371a1a9e7e53b5b8e1400c76dcd9f7b21d618758e25ef98da3784a5968bd78af1dc8f78845357b1bffbae65d2753a086e3734b3ff7ecf62b1829770f09d
+EBUILD aiohttp-socks-0.2.2.ebuild 910 BLAKE2B 54c6dbbe842bea798ec60d15e6cf1621db8a389237b70234d0b1932207729f5f8864bb83ac9880295e144a5711191bd33658f321199ab6f7f5df063cb6afb78d SHA512 c8b121e6f22b6d0a8ef15c616483ab90afc6142e59cf74982b1942fc17331cfe502fa43cb786cd82161857ab392fe928f5c92b8533404c32ea71c3628a8dea10
MISC metadata.xml 391 BLAKE2B b2c143f0bebedd76ce3992254b7c068b9707bcc75c552cf994239fbcd32ecb39c981a1a61bd351c29627fc4a65124fb54b5c8533fba5f8638d17b253893e50b5 SHA512 4519a8f883d724ea786cb00023c8e0efae8d343d40c0988154efd27a2bdce7b73e6884f3f406109fabef54b9e2d62e8c07cda7e7d876b148cff0090ba38c2104
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
index 7e449920dc7f..9b27fc1c0416 100644
--- a/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.2.2.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
-PYTHON_COMPAT=( python3_6 )
+PYTHON_COMPAT=( python3_{6,7} )
inherit distutils-r1
@@ -13,11 +13,27 @@ SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/${PV}.tar.gz -> ${P}
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
+KEYWORDS="amd64 x86"
+IUSE="test"
+# Tests require Internet access
+RESTRICT="test"
-RDEPEND="
- >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
-"
+RDEPEND=">=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ net-proxy/3proxy
+ )"
-DOCS=( README.md )
+python_configure_all() {
+ rm tests/3proxy/bin/*/* || die
+ if use test; then
+ ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
+ fi
+}
+
+python_test() {
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}