summaryrefslogtreecommitdiff
path: root/dev-python/aiohttp-socks
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-08-25 10:45:55 +0100
commit3cf7c3ef441822c889356fd1812ebf2944a59851 (patch)
treec513fe68548b40365c1c2ebfe35c58ad431cdd77 /dev-python/aiohttp-socks
parent05b8b0e0af1d72e51a3ee61522941bf7605cd01c (diff)
gentoo resync : 25.08.2020
Diffstat (limited to 'dev-python/aiohttp-socks')
-rw-r--r--dev-python/aiohttp-socks/Manifest4
-rw-r--r--dev-python/aiohttp-socks/aiohttp-socks-0.5.3.ebuild44
-rw-r--r--dev-python/aiohttp-socks/metadata.xml1
3 files changed, 48 insertions, 1 deletions
diff --git a/dev-python/aiohttp-socks/Manifest b/dev-python/aiohttp-socks/Manifest
index 09846c5a23d2..64265d369432 100644
--- a/dev-python/aiohttp-socks/Manifest
+++ b/dev-python/aiohttp-socks/Manifest
@@ -1,3 +1,5 @@
DIST aiohttp-socks-0.2.2.tar.gz 1351798 BLAKE2B 40c9e033de523cad365e95051d48dee5fbd3d964e7b3864393c54d23394a5cfcfcb46cb9d78f25a6101bc97034c77c5a75aef94cfb962054c29bd804e387b0a9 SHA512 218c262cb3eab74166686614ab5a720c31d1ce886cfd655f296c930f648b1d94e909724346769a46b600b8f1bc8ddbc498ee75cd5854e409566a8ead6a7efdab
+DIST aiohttp-socks-0.5.3.tar.gz 1360418 BLAKE2B 7282a4952d5f0301b14291a1892db5ec058af91cf553e4a17ab0e933bb327d1fae9c015d25ff7405ef69cdf56637140fefa9bd1ab1e6f2e224cdc94b9e279159 SHA512 2999f850081d05c31535c24c0fcf0948dbaaec5e421c28ed4ca68b4bfb122f881942e7e829cefc01377212b4579547aafcf273fe5a999acb3d158ee1c3f0a888
EBUILD aiohttp-socks-0.2.2.ebuild 910 BLAKE2B 54c6dbbe842bea798ec60d15e6cf1621db8a389237b70234d0b1932207729f5f8864bb83ac9880295e144a5711191bd33658f321199ab6f7f5df063cb6afb78d SHA512 c8b121e6f22b6d0a8ef15c616483ab90afc6142e59cf74982b1942fc17331cfe502fa43cb786cd82161857ab392fe928f5c92b8533404c32ea71c3628a8dea10
-MISC metadata.xml 391 BLAKE2B b2c143f0bebedd76ce3992254b7c068b9707bcc75c552cf994239fbcd32ecb39c981a1a61bd351c29627fc4a65124fb54b5c8533fba5f8638d17b253893e50b5 SHA512 4519a8f883d724ea786cb00023c8e0efae8d343d40c0988154efd27a2bdce7b73e6884f3f406109fabef54b9e2d62e8c07cda7e7d876b148cff0090ba38c2104
+EBUILD aiohttp-socks-0.5.3.ebuild 1060 BLAKE2B 16d9962b6763a77a3aec39bac71d26feb2e781f97a1438e4da1805f7caa13f853eea7dc3df8ac4c30695f396f54142f687bb19f0310db00452d09d0ed5bfc452 SHA512 3933ddc26d565605716ac7df2e60be94859a325b9498d0fadac05ffa8a0fc87edeebf6b041d9b91698e15cb18421fba491dd818138e38a94fe7964d8defe9c71
+MISC metadata.xml 416 BLAKE2B fd462ceb91bb4032d944cfe0a6f040120e2492a2aab5a34e6d6416ee9dceb51df7fe3b12cf125415989ac7c2be72d609a1955ebc825cb8e9eaa16dc28df89532 SHA512 6712e24058ed1a73dc03eaca9537df0f6ddaace9a5391cfb01453a342bd8ee5d81ba602e582490bf647bce3665567c6cdadcf4d2b92730f77f79654a309fcc20
diff --git a/dev-python/aiohttp-socks/aiohttp-socks-0.5.3.ebuild b/dev-python/aiohttp-socks/aiohttp-socks-0.5.3.ebuild
new file mode 100644
index 000000000000..2be59ad90cdf
--- /dev/null
+++ b/dev-python/aiohttp-socks/aiohttp-socks-0.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="SOCKS proxy connector for aiohttp"
+HOMEPAGE="https://pypi.org/project/aiohttp-socks/"
+SRC_URI="https://github.com/romis2012/aiohttp-socks/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+# Tests require Internet access, also they started failing when run
+# via ebuild (but work fine externally)
+RESTRICT="test"
+
+# TODO: optional dep on trio
+RDEPEND="
+ >=dev-python/aiohttp-2.3.2[${PYTHON_USEDEP}]
+ >=dev-python/attrs-19.2.0[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ net-proxy/3proxy
+ )"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # TODO: reenable when trio is packaged
+ rm tests/test_core_socks_async_trio.py || die
+ distutils-r1_src_prepare
+}
+
+python_configure_all() {
+ rm tests/3proxy/bin/*/* || die
+ if use test; then
+ ln -s "$(type -P 3proxy)" tests/3proxy/bin/linux/ || die
+ fi
+}
diff --git a/dev-python/aiohttp-socks/metadata.xml b/dev-python/aiohttp-socks/metadata.xml
index 829f4a58e8e5..b6e998bee27f 100644
--- a/dev-python/aiohttp-socks/metadata.xml
+++ b/dev-python/aiohttp-socks/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">aiohttp-socks</remote-id>
<remote-id type="github">romis2012/aiohttp-socks</remote-id>