summaryrefslogtreecommitdiff
path: root/dev-python/aiohappyeyeballs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-01-07 00:55:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-01-07 00:55:44 +0000
commitf986d7fe50cd66c636620a90125850ff8d0f4a1c (patch)
tree51954bbef2363456f65ed2724742a0e781663249 /dev-python/aiohappyeyeballs
parentcf7a256641d0729742707e68efe5e5ee3895b6c9 (diff)
gentoo auto-resync : 07:01:2024 - 00:55:44
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest3
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild36
-rw-r--r--dev-python/aiohappyeyeballs/metadata.xml12
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
new file mode 100644
index 000000000000..afaee112f3da
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -0,0 +1,3 @@
+DIST aiohappyeyeballs-2.3.1.gh.tar.gz 46348 BLAKE2B 6d20cd6db085b7d7bd0b2a18eec01dbd569eb64be7ae953eadcd07e161442637fee9ec63c3bb2253d11fea210d9ab6e8a130f9f036652a8965325db9fc30d3dd SHA512 c02a12a269e0733f653df9fedc150aea8ad061fb8b1f67e3519d6c2e8ea92f8ad3360b4eaacc0e55f51e81f57cc9c8aa82dbe0fcd9779dcd8151a3f944f28847
+EBUILD aiohappyeyeballs-2.3.1.ebuild 705 BLAKE2B 2f5996944b8e4fa016cc44b45f740a74cc0debb887f0bc57c6661b1ff670ca8475d07283cbb93c1063d152baa18993ccc56c16ede039327ff9dde4b35a4aead4 SHA512 5a8917d6cf59a67728e7ad195d0a7e00fdfceb41db0223cc68bafdda9babcd302f322bbf80f07d4251c59fd136e600aa47959fc908114f105bac4b2809b0cfc1
+MISC metadata.xml 387 BLAKE2B c739dc88d077c51dae10eb7aaa84091c6c7904a782ee3eabb12b6167c7e4ae8528b6464612f891eef5f12add728caa66fd30cd93c3b13e022cedae267c1e9f40 SHA512 65973b766dbcbd20b8c25e8e76c4d662bf5478d6c860f8cfd460be8795fbd141c58fed586a678506360af8ac013ec4c2292cc2e1092a5bbd8a3c54160adadb94
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild
new file mode 100644
index 000000000000..93d57735e419
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}
diff --git a/dev-python/aiohappyeyeballs/metadata.xml b/dev-python/aiohappyeyeballs/metadata.xml
new file mode 100644
index 000000000000..5f0349700b9f
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">aio-libs/aiohappyeyeballs</remote-id>
+ <remote-id type="pypi">aiohappyeyeballs</remote-id>
+ </upstream>
+</pkgmetadata>