summaryrefslogtreecommitdiff
path: root/dev-python/aiohappyeyeballs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-08-07 12:37:21 +0100
commitb8c7370a682e4e29cda623222d17a790c01c3642 (patch)
treef6caa14689bd00a5760eadaa381ff41e50ef3c1b /dev-python/aiohappyeyeballs
parent8a4997a7e2d1e36c089d4d76935b5a902d98d3d0 (diff)
gentoo auto-resync : 07:08:2024 - 12:37:20
Diffstat (limited to 'dev-python/aiohappyeyeballs')
-rw-r--r--dev-python/aiohappyeyeballs/Manifest2
-rw-r--r--dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild36
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/aiohappyeyeballs/Manifest b/dev-python/aiohappyeyeballs/Manifest
index e7268ed0a7f9..c3cb73703a5d 100644
--- a/dev-python/aiohappyeyeballs/Manifest
+++ b/dev-python/aiohappyeyeballs/Manifest
@@ -1,3 +1,5 @@
DIST aiohappyeyeballs-2.3.2.gh.tar.gz 46204 BLAKE2B 85a050910181e7acd6520ae8126e6e1656b5d5e7d869bca481af5fe65b52bf1d4dc0502d2e0cce702c60dc9420757fc892a91a600a73925adce6990fc224bb1a SHA512 5638dabb06c9d0182e21371470d612ec78a1a8981a0720318b0f4fc0569b7c556adfba6297b5bec75726e106f5a6335acfb19bd5322e43e5ebc4f71d4457424c
+DIST aiohappyeyeballs-2.3.4.gh.tar.gz 54416 BLAKE2B ca3f34af2d20528c229b6beba0896a7a2e6dc86a83310c36163c2213232d3222e8ba9eafc23461c5d79fae7af6a06127691ddfb582e12c3d402ee452c42803a0 SHA512 75adf8164e287113fb176f5f814f929dac57834941ba83eeec4c2e9aa28585c4659bc18fe7d7b010e9f53ee81d3a5b3727175ed981d4ec846e6209428a2516eb
EBUILD aiohappyeyeballs-2.3.2.ebuild 780 BLAKE2B 6600e87b0a708978ee634d22930da264a6f4cd67b0184f6dfaaba73dc6cccd9ce9eed3ea33c809b08341045ca5e1e8bd9ed09354779d8caa1a58607624ea8551 SHA512 c3b363f9d365343159583042b9e950e1e2ae1015168b3b500b2e537fdc4d910f101dd39494322a86a95a964b4cf22e305ed16a6d1e065ea844e4a50668b0b774
+EBUILD aiohappyeyeballs-2.3.4.ebuild 780 BLAKE2B 6600e87b0a708978ee634d22930da264a6f4cd67b0184f6dfaaba73dc6cccd9ce9eed3ea33c809b08341045ca5e1e8bd9ed09354779d8caa1a58607624ea8551 SHA512 c3b363f9d365343159583042b9e950e1e2ae1015168b3b500b2e537fdc4d910f101dd39494322a86a95a964b4cf22e305ed16a6d1e065ea844e4a50668b0b774
MISC metadata.xml 387 BLAKE2B c739dc88d077c51dae10eb7aaa84091c6c7904a782ee3eabb12b6167c7e4ae8528b6464612f891eef5f12add728caa66fd30cd93c3b13e022cedae267c1e9f40 SHA512 65973b766dbcbd20b8c25e8e76c4d662bf5478d6c860f8cfd460be8795fbd141c58fed586a678506360af8ac013ec4c2292cc2e1092a5bbd8a3c54160adadb94
diff --git a/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild
new file mode 100644
index 000000000000..05fb16344a39
--- /dev/null
+++ b/dev-python/aiohappyeyeballs/aiohappyeyeballs-2.3.4.ebuild
@@ -0,0 +1,36 @@
+# Copyright 2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Happy Eyeballs for pre-resolved hosts"
+HOMEPAGE="
+ https://pypi.org/project/aiohappyeyeballs/
+ https://github.com/aio-libs/aiohappyeyeballs/
+"
+SRC_URI="
+ https://github.com/aio-libs/aiohappyeyeballs/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ >=dev-python/pytest-asyncio-0.23.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p asyncio -o addopts=
+}