summaryrefslogtreecommitdiff
path: root/dev-python/aiofiles/aiofiles-23.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-12 09:56:54 +0000
commitebc282ef4dfa408accac685565b8ee5f6faec119 (patch)
treec0a4f713228cda0ab17eed46f0bb7ca8cb8be2f6 /dev-python/aiofiles/aiofiles-23.1.0.ebuild
parent6c8694a707151d59555b0e4e48235f085ce166c3 (diff)
gentoo auto-resync : 12:02:2023 - 09:56:54
Diffstat (limited to 'dev-python/aiofiles/aiofiles-23.1.0.ebuild')
-rw-r--r--dev-python/aiofiles/aiofiles-23.1.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aiofiles/aiofiles-23.1.0.ebuild b/dev-python/aiofiles/aiofiles-23.1.0.ebuild
new file mode 100644
index 000000000000..b8347ab03843
--- /dev/null
+++ b/dev-python/aiofiles/aiofiles-23.1.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="File support for asyncio"
+HOMEPAGE="
+ https://github.com/Tinche/aiofiles/
+ https://pypi.org/project/aiofiles/
+"
+SRC_URI="
+ https://github.com/Tinche/aiofiles/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest