summaryrefslogtreecommitdiff
path: root/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-29 09:16:49 +0100
commitb2d3769042cfd3d8ceadaa52f6a5aafabb0d4114 (patch)
tree4fcc91b967ba153d4030d61e10f1b07b53755488 /dev-python/aiodns/aiodns-3.0.0-r1.ebuild
parent2d3042634af4767714cb90eff3f773ef54afb5ed (diff)
gentoo auto-resync : 29:05:2023 - 09:16:49
Diffstat (limited to 'dev-python/aiodns/aiodns-3.0.0-r1.ebuild')
-rw-r--r--dev-python/aiodns/aiodns-3.0.0-r1.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/dev-python/aiodns/aiodns-3.0.0-r1.ebuild b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
index fd48e2ce2eb3..1a5434f93ef6 100644
--- a/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
+++ b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
+PYTHON_COMPAT=( python3_{10..12} )
inherit distutils-r1 pypi
@@ -22,9 +22,18 @@ RESTRICT="test"
RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}"
-distutils_enable_tests unittest
+distutils_enable_tests pytest
PATCHES=(
# https://github.com/saghul/aiodns/commit/146286601fe80eb4ede8126769e79b5d5e63f64e
"${FILESDIR}/${P}-py3.10-tests.patch"
)
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # Internet changed, https://github.com/saghul/aiodns/issues/107
+ tests.py::DNSTest::test_query_bad_chars
+ )
+
+ epytest tests.py
+}