summaryrefslogtreecommitdiff
path: root/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 21:08:17 +0100
commit496936ff0f7db69d1f7317341230acb866e3c330 (patch)
tree1541e919cd45c0ab5bdee8f1ac1344508da3b3af /dev-python/aiodns/aiodns-3.0.0-r1.ebuild
parentc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (diff)
gentoo auto-resync : 29:07:2022 - 21:08:17
Diffstat (limited to 'dev-python/aiodns/aiodns-3.0.0-r1.ebuild')
-rw-r--r--dev-python/aiodns/aiodns-3.0.0-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/aiodns/aiodns-3.0.0-r1.ebuild b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
new file mode 100644
index 000000000000..3b55866582f3
--- /dev/null
+++ b/dev-python/aiodns/aiodns-3.0.0-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple DNS resolver for asyncio"
+HOMEPAGE="https://github.com/saghul/aiodns/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+
+# Tests fail with network-sandbox, since they try to resolve google.com
+PROPERTIES="test_network"
+RESTRICT="test"
+
+RDEPEND=">=dev-python/pycares-3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+distutils_enable_tests unittest
+
+PATCHES=(
+ # https://github.com/saghul/aiodns/commit/146286601fe80eb4ede8126769e79b5d5e63f64e
+ "${FILESDIR}/${P}-py3.10-tests.patch"
+)