summaryrefslogtreecommitdiff
path: root/dev-python/agate
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-11 00:10:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-11 00:10:45 +0100
commit82002be95de85b10f5953f5e10ced81a40ec1fba (patch)
tree3e95915eeab9799a67d9b0c508260ca31a4694ab /dev-python/agate
parentfc6ff4de73d70ead4ce3a005b4f5328f2b23129b (diff)
gentoo auto-resync : 11:10:2023 - 00:10:45
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest2
-rw-r--r--dev-python/agate/agate-1.8.0.ebuild44
2 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index eed94bacfe7a..958e3aa240d8 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,3 +1,5 @@
DIST agate-1.7.1.tar.gz 202018 BLAKE2B 9df0f108f1ac47c1eb199015aedc903d72ce62a7d2c34198f0f287863527a2305c5682ef7dd385d130fd0eb3ce566e98978b9ef438858510e3aeae02a6345318 SHA512 e40df26f1e738b4c386f540d642f4fdb240dac5229032c6074977a67c7fdae7838c770703d93916e10741a9f2569ac9672165f8c8715b2567b2e5b926c7dabd5
+DIST agate-1.8.0.tar.gz 201730 BLAKE2B c0138f912d6981059b8cd62424bdb428c9b6bff566bc47466bea9f0fd78f100333583dddaf081ea2f9810e8a1e586d4697960141ea4e97e8cef4a5084f09ce78 SHA512 9870f31f87efcb057947cf0c93062c2dbfa2aa996d1e6d69c552935eca3ab5c047ea0cbdf2eaca8e37d2a0530d210318fd342324f1ce43d7cba9f6291206f6fb
EBUILD agate-1.7.1.ebuild 1133 BLAKE2B e4eebdadb1598214cd15244bab87622b16a1afd8248ef5c8b1ebcfe96fe96defca6a436b52bdca7a8b91cceef74910604cb36222eba9a6022c060f9efe9b0dd5 SHA512 ea1287f7bfff8eb835309ec03c9518e0f7fddaef28a77656ba66a94b450b661fa2c3621593766c001f7c141103c99141a5b7951e847717c3a4e52a91e6d12293
+EBUILD agate-1.8.0.ebuild 1122 BLAKE2B 3e4bd01a37455a15a741bc3ad35767186f84c88b2fd7ae703eda57d52941fdd75e899bb4e9c26ea894329748c6a960eef78870c450db69eb68111ef2049811a4 SHA512 a7ccbad1830c0b74c1b97d6db4910f425afb554b608ee8d7f7a6eb978db9361e4957ee7df9b54adc8a36777efca19f058720a9b4855828b3a7eb8ac6bffb0d30
MISC metadata.xml 611 BLAKE2B a288b63c7859d99467f9304b4d8b007b9df6b4345157e3b7363f23757797fa7f84420b8a515f754775de14893c2fba1ddd62fc3757f5b96f791f65b524db41f7 SHA512 3101db1d600b60da2704dd732b898db6d932ef2305a28dbfdc8b221fc7938a72309e1fd27af4567b4930a20f00490ad8d65bd962978df44cf401ddd058442f02
diff --git a/dev-python/agate/agate-1.8.0.ebuild b/dev-python/agate/agate-1.8.0.ebuild
new file mode 100644
index 000000000000..bf35fa27a14c
--- /dev/null
+++ b/dev-python/agate/agate-1.8.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)