summaryrefslogtreecommitdiff
path: root/dev-python/aesara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-25 23:34:28 +0100
commit5b14ea000f5782ac047162ffc35ef8c3c0648b4a (patch)
tree9bd4130367f85e9308e6d6c6b12ba58759b5f789 /dev-python/aesara
parent85261a4d217482e1c124937d57ec98a0aabaee59 (diff)
gentoo auto-resync : 25:09:2022 - 23:34:28
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest2
-rw-r--r--dev-python/aesara/aesara-2.8.6.ebuild102
2 files changed, 104 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 0e4cb3c415f0..6abecba0b193 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,4 +1,6 @@
AUX aesara-2.6.5-compiledir-tid.patch 1707 BLAKE2B 77f8fa3618f930dddad8e864dee3e73fc0b965018d508be5877d5bcae4430024c4e4f90e905ac912da22a4d4934d6fc71acf4ebd49b7e8efb12c90dfaa072ed2 SHA512 9b6bbd8bc56f61c89dfd85cb18251ff8d73d717d91178efa9309e6b897dbda28937dea84f1d7d1a917c285219d51c0adcee1233112f2dcdb9f8c7b714a6c6c12
DIST aesara-rel-2.7.9.gh.tar.gz 7919763 BLAKE2B f877edcc824f3d790a56422a0fa660e8e3f653fff7e3d87ef4a95fa76369b1bb5df351a571ea039d66d79c0f564512437672df76c3b82e7d660c865cf908dea3 SHA512 061f7e39343eb081b28dd20b1eb7ffc226b7e4b96695d5beb9e28eb3f5ec9480c02c7889c932290248baa908dc0047c19e4cef3c220eccc4cc617b2050a9614e
+DIST aesara-rel-2.8.6.gh.tar.gz 7941385 BLAKE2B 8e01e8afe7a4a33ad133d2759336dea66223c7f001c963d937bcae903f315b4dffbd0e877fbfe2f1b7f31b7f73acd8b7ac38a716337aa129b9a36b0367715f96 SHA512 abfa9f63f096eb6d8961eaa700a13f41833ba79d684b83fbcd7bf4a9d8f0ab49eae1bc3d1249817cf03f63526127612482cbc79c03bf2596743caca810f1fc56
EBUILD aesara-2.7.9.ebuild 2746 BLAKE2B 3ddf8cc5b6315569f61be3d43d8f7d8f1e484657024462ef9466cd6e06e01377a18e015157d799a95b661677a9d165dd445903d305c99dc2c2f8b40a477c226f SHA512 7f37bd5c185747f64a3b77603df2c09113aabd0cd38e04e6df3a107342342f8d9eaaa824cc999db137ec9177ee0e4de5c10dbaa35937ab745145034f941add44
+EBUILD aesara-2.8.6.ebuild 2929 BLAKE2B 6b8a83d3c5353f7442cf8949a589f14e89d2ba76fc0929118df58becf9374d4a76060cf1c3570d80ef28bd0f3c7c0198afd453adabeac71ff074c94c43012224 SHA512 9f9be4b85882008b4acebab068e0d6e386c171196f2e2ae4d41f75f673d522006408a754ea17c2c6f06394dfd497fd33a31be1f74b700c9ad1719d21d3d48948
MISC metadata.xml 506 BLAKE2B be65b6be62282fa47152985d79892fd04105a47e00a427ee8341d27aeff21b144bee7e7d0f16b2f4b617c941bdf5ebd9de37a42c39d117cdfd579c3035d35a74 SHA512 a207ec3db85a8e6f03feabd14da588f0b9ca9a88ab2495ade0f40b516b3bbd20fe78b14698d28da7ceed238737a9f4d63f587156ef609e846b485132d598c6bb
diff --git a/dev-python/aesara/aesara-2.8.6.ebuild b/dev-python/aesara/aesara-2.8.6.ebuild
new file mode 100644
index 000000000000..00f30feaabf6
--- /dev/null
+++ b/dev-python/aesara/aesara-2.8.6.ebuild
@@ -0,0 +1,102 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 multiprocessing optfeature
+
+MY_P=aesara-rel-${PV}
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="
+ https://github.com/aesara-devs/aesara/
+ https://pypi.org/project/aesara/
+"
+SRC_URI="
+ https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/minikanren[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ <dev-python/numpy-1.23[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-48.0.0[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
+)
+
+distutils_enable_sphinx doc 'dev-python/sphinx_rtd_theme'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not claim "bin" package (sic!)
+ rm bin/__init__.py || die
+ sed -e 's/find:/find_namespace:/' \
+ -e '/exclude =/a\ doc*' \
+ -i setup.cfg || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+
+ # dunno
+ 'tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak[False]'
+
+ # TODO
+ tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
+ tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
+ tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
+ )
+ local EPYTEST_IGNORE=(
+ # we do not package jax or numba
+ tests/link/jax
+ tests/link/numba
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x AESARA_FLAGS="cxx=${CXX}"
+ AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
+ AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
+
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+ # clean up the compiledir, as it can grow pretty large
+ rm -r "${HOME}"/.aesara || die
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit dev-util/nvidia-cuda-sdk
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}