summaryrefslogtreecommitdiff
path: root/dev-python/aesara
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-11 23:47:37 +0100
commit02930d1eb5af78d32b1597af6af24163895d9e0f (patch)
tree7908188ca5a80d7ff557ebc70fe3bdcbf2875832 /dev-python/aesara
parent54654470d999265b5a0010be7190e8a9993b1840 (diff)
gentoo auto-resync : 11:05:2023 - 23:47:37
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest2
-rw-r--r--dev-python/aesara/aesara-2.9.0.ebuild105
2 files changed, 107 insertions, 0 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index fb3b9057457e..518660851359 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,5 +1,7 @@
AUX aesara-2.6.5-compiledir-tid.patch 1707 BLAKE2B 77f8fa3618f930dddad8e864dee3e73fc0b965018d508be5877d5bcae4430024c4e4f90e905ac912da22a4d4934d6fc71acf4ebd49b7e8efb12c90dfaa072ed2 SHA512 9b6bbd8bc56f61c89dfd85cb18251ff8d73d717d91178efa9309e6b897dbda28937dea84f1d7d1a917c285219d51c0adcee1233112f2dcdb9f8c7b714a6c6c12
AUX aesara-2.8.10-fix-tuple.patch 649 BLAKE2B bfc2b2971fdaa452c5d14d75f68af5931b979dcb2951baf8bb1cf759058b4c0f341233b33d907722302ea8374cbd965e4d09e87f069ee2b1a558bf4e9a7309c9 SHA512 2c5846c723f214a8f623593f518194edb113f0d7c64ab1d69d6e4c5278125910f1c775cffdb46871d23ddf5332bbd84f252ed58e2560663c0c36520f1fb72372
+DIST aesara-2.9.0.tar.gz 4421520 BLAKE2B e0c1cc0c48313c84c1ebe99e04e9d097bd37d63f7948b81df77538d647853233378aa2f2b985c1ab6e7f22adf47abef243addadad3505f332e465e1569d31e17 SHA512 2f36e5f462dc3dc36a0f7d7e99b01ae2be5091c2e6127d1f079245b104ce21cee7afff4dc4ade403e2e8a0dffa5feda2e0e9d4bd734192350672c85c36390c4b
DIST aesara-rel-2.8.12.gh.tar.gz 4582575 BLAKE2B d212e41fd22b54335bcc6f7a744d51113b1cfbad011480eabfde1b72cef5955ce019f2ee2a821d4cea22aa4340a2537156e3f4a5a1962ae0f23107d20df3d70a SHA512 c65e63efa1d6e9de0df6db6f96226d6f830198626a3dc7e77a977e3260ab276745b9c8ae5fa9ea48edb9aee9d88c8181e7a7e19aaa49e51290e4df619e227bbf
EBUILD aesara-2.8.12.ebuild 3420 BLAKE2B aa1535e2bd4b4b5112af31518a66beda3032d32f89c137fad36e37ada1a167e9ec7b1ea75da00f5be2d4aa2cd3877e147412692664a5c3048f1bfc20bf59e257 SHA512 147e664570e2f0cd9eae47893e7ce944ef7c7cf49ceb93575def15e1b3016dac8762e3462eb0684ac1dbdb0de229981b1e61600360273c29a8b70aec275bdc9d
+EBUILD aesara-2.9.0.ebuild 3285 BLAKE2B 06c334b9f6f6e7979af9528b79755f2a815f9457484649c2558fc87163858b44e559d0fb4cfe170a8d9fa41422ba9dde5e90d4b2611a9b7f55e59685e5a2233c SHA512 31c1adeaf2339cb7aa9149b34374274623e73fb49b62af802a8f38b056577a5aee662af68c3a8f690e2cf49e24f274450bcb3400cfb572242ea4f56bee01c357
MISC metadata.xml 506 BLAKE2B be65b6be62282fa47152985d79892fd04105a47e00a427ee8341d27aeff21b144bee7e7d0f16b2f4b617c941bdf5ebd9de37a42c39d117cdfd579c3035d35a74 SHA512 a207ec3db85a8e6f03feabd14da588f0b9ca9a88ab2495ade0f40b516b3bbd20fe78b14698d28da7ceed238737a9f4d63f587156ef609e846b485132d598c6bb
diff --git a/dev-python/aesara/aesara-2.9.0.ebuild b/dev-python/aesara/aesara-2.9.0.ebuild
new file mode 100644
index 000000000000..39e0ded3a685
--- /dev/null
+++ b/dev-python/aesara/aesara-2.9.0.ebuild
@@ -0,0 +1,105 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 multiprocessing optfeature pypi
+
+DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
+HOMEPAGE="
+ https://github.com/aesara-devs/aesara/
+ https://pypi.org/project/aesara/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/cons[${PYTHON_USEDEP}]
+ dev-python/etuples[${PYTHON_USEDEP}]
+ dev-python/logical-unification[${PYTHON_USEDEP}]
+ dev-python/minikanren[${PYTHON_USEDEP}]
+ dev-python/filelock[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
+ "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
+)
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not claim "bin" package (sic!)
+ rm bin/__init__.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # speed tests are unreliable
+ tests/scan/test_basic.py::test_speed
+ tests/scan/test_basic.py::test_speed_rnn
+ tests/scan/test_basic.py::test_speed_batchrnn
+ tests/link/test_vm.py::test_speed
+ tests/link/test_vm.py::test_speed_lazy
+ tests/tensor/test_gc.py::test_merge_opt_runtime
+
+ # rounding problem?
+ # https://github.com/aesara-devs/aesara/issues/477
+ tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
+ tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
+
+ # Deprecation warning causes unexpected additional output
+ tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
+
+ # dunno
+ tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
+ tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
+
+ # TODO
+ tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
+ tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
+ tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
+
+ # TODO: Package pytest-benchmark
+ tests/scan/test_basic.py::TestExamples::test_reordering
+ tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
+ tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
+ tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
+ tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
+ tests/scan/test_basic.py::test_cython_performance
+ )
+ local EPYTEST_IGNORE=(
+ # we do not package jax or numba
+ tests/link/jax
+ tests/link/numba
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x AESARA_FLAGS="cxx=${CXX}"
+ AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
+ AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
+
+ epytest -p xdist.plugin -n "$(makeopts_jobs)"
+ # clean up the compiledir, as it can grow pretty large
+ rm -r "${HOME}"/.aesara || die
+}
+
+pkg_postinst() {
+ optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
+ optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
+}