summaryrefslogtreecommitdiff
path: root/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-23 18:45:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-23 18:45:51 +0000
commit3bd958e646e508a3e80f5fb28f44384eed671f5d (patch)
tree59c64eff7f35adeaabe15243171164094a9c23e1 /dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
parentc8c3804588db08dae281504dd79ef71741cd8dc3 (diff)
gentoo auto-resync : 23:03:2023 - 18:45:51
Diffstat (limited to 'dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild')
-rw-r--r--dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild b/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
new file mode 100644
index 000000000000..5f12c88e0e4d
--- /dev/null
+++ b/dev-python/accessible-pygments/accessible-pygments-0.0.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of accessible pygments styles"
+HOMEPAGE="
+ https://pypi.org/project/accessible-pygments/
+ https://github.com/Quansight-Labs/accessible-pygments/
+"
+SRC_URI="
+ https://github.com/Quansight-Labs/accessible-pygments/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pygments-1.5[${PYTHON_USEDEP}]
+"
+
+python_test() {
+ # it's more like a demo but at least checks if all themes can
+ # be loaded and run; we can't reasonably compare the results
+ # because they differ by pygments version a lot
+ "${EPYTHON}" test/run_tests.py || die
+}