summaryrefslogtreecommitdiff
path: root/dev-python/absl-py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-17 08:06:58 +0000
commit29394d0921808a94a409f01eff49f681651de5d5 (patch)
tree93d18027cb4ea68a3c967602c5793af032180bab /dev-python/absl-py
parent5987fa693ef880163ebde423615a177cb5bda20e (diff)
gentoo auto-resync : 17:02:2023 - 08:06:58
Diffstat (limited to 'dev-python/absl-py')
-rw-r--r--dev-python/absl-py/Manifest2
-rw-r--r--dev-python/absl-py/absl-py-1.3.0.ebuild79
2 files changed, 0 insertions, 81 deletions
diff --git a/dev-python/absl-py/Manifest b/dev-python/absl-py/Manifest
index 05b5d56c9c15..004a333c785d 100644
--- a/dev-python/absl-py/Manifest
+++ b/dev-python/absl-py/Manifest
@@ -1,5 +1,3 @@
-DIST abseil-py-1.3.0.gh.tar.gz 224655 BLAKE2B 7f5c329c159a3b8d3fd7fc37ab36649d7711120ab41a2c052deb383aeae115b8ffe22e0f9c933e6cfe83e19013a2733d037954411f0f6d4acde1a7ecb3131973 SHA512 5631368b1f86dbc73d5261dc07a2693c8effb2534745fe4f19db26f908c7afff9f440a1545f16d1356092ac9a9fda2fdde97fc8977100e162765d9c224d7a66d
DIST abseil-py-1.4.0.gh.tar.gz 228096 BLAKE2B c34e6319d69976631a4b674d4f23eb0a11705c69fc1ce740eb2b570c61cc3507634d73699eb023b94fe6042c2f49eba3ec134c9c08958aca904eea3bfb8f84e7 SHA512 45cbf6f90a14a3d6e07ee0a6407d4521cac8d15340885c6ae790180c255dfea54e862ee2d806c166a28b5ce238720a7e3af25d6ffe054820588d4a0f20e1f124
-EBUILD absl-py-1.3.0.ebuild 2536 BLAKE2B 6c48ca30e06c8c4085176a3f17065bf21b2cd0aac40c388f91a97218eb35525824c82279545b71c75d5698846172960e9aa92e3230c60d92e6e23d1f7667f47a SHA512 a66979017c21dfd0811e80eed31310a6af7d446792f171c127e477fb64edfb446d567f8404903036c0329caedc29f21aa4d97ecd65f5cca15ea53e09255b65d7
EBUILD absl-py-1.4.0.ebuild 2536 BLAKE2B 6c48ca30e06c8c4085176a3f17065bf21b2cd0aac40c388f91a97218eb35525824c82279545b71c75d5698846172960e9aa92e3230c60d92e6e23d1f7667f47a SHA512 a66979017c21dfd0811e80eed31310a6af7d446792f171c127e477fb64edfb446d567f8404903036c0329caedc29f21aa4d97ecd65f5cca15ea53e09255b65d7
MISC metadata.xml 577 BLAKE2B dd0e02b24bdb42f24bd675cadf13e99f861a6dc9be2879f671b9bc4e9e078ef81759909e81e3063cb54c71ff71d6609624f0cf2645bf6ec055c643fbb0f3ab5c SHA512 7cfa86cac5d38b10aedacdb4bafc7acbd11cf4a98a873a2435ef5761d5186c5128171eb286b2d2568a1a353eb4de815303eae225cf5823a5292ac362633b67c7
diff --git a/dev-python/absl-py/absl-py-1.3.0.ebuild b/dev-python/absl-py/absl-py-1.3.0.ebuild
deleted file mode 100644
index c7c5c3511cff..000000000000
--- a/dev-python/absl-py/absl-py-1.3.0.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-MY_P=abseil-py-${PV}
-DESCRIPTION="Abseil Python Common Libraries"
-HOMEPAGE="
- https://github.com/abseil/abseil-py/
- https://pypi.org/project/absl-py/
-"
-SRC_URI="
- https://github.com/abseil/abseil-py/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 x86"
-
-RDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
-
-src_prepare() {
- # what a nightmare... well, we could have called bazel but that would
- # even worse
- local helpers=(
- absl/flags/tests/argparse_flags_test_helper.py:absl/flags/tests/argparse_flags_test_helper
- absl/logging/tests/logging_functional_test_helper.py:absl/logging/tests/logging_functional_test_helper
- absl/testing/tests/absltest_fail_fast_test_helper.py:absl/testing/tests/absltest_fail_fast_test_helper
- absl/testing/tests/absltest_filtering_test_helper.py:absl/testing/tests/absltest_filtering_test_helper
- absl/testing/tests/absltest_randomization_testcase.py:absl/testing/tests/absltest_randomization_testcase
- absl/testing/tests/absltest_sharding_test_helper.py:absl/testing/tests/absltest_sharding_test_helper
- absl/testing/tests/absltest_test_helper.py:absl/testing/tests/absltest_test_helper
- absl/testing/tests/xml_reporter_helper_test.py:absl/testing/tests/xml_reporter_helper_test
- absl/tests/app_test_helper.py:absl/tests/app_test_helper_pure_python
- )
-
- local x
- for x in "${helpers[@]}"; do
- local script=${x%:*}
- local sym=${x#*:}
- sed -i -e "1i#!/usr/bin/env python" "${script}" || die
- chmod +x "${script}" || die
- ln -s "${script##*/}" "${sym}" || die
- done
-
- # i don't wanna know how these pass for upstream with wrong helper names
- sed -i -e 's:\(app_test_helper\)\.py:\1_pure_python:' \
- absl/tests/app_test.py || die
- sed -i -e 's:\(logging_functional_test_helper\)\.py:\1:' \
- absl/logging/tests/logging_functional_test.py || die
-
- distutils-r1_src_prepare
-}
-
-python_test() {
- local -x PYTHONPATH=.
- local fails=0
- while read -r -d '' x; do
- ebegin "${x}"
- "${EPYTHON}" "${x}"
- eend ${?} || : "$(( fails += 1 ))"
- done < <(find -name '*_test.py' -print0)
-
- [[ ${fails} -ne 0 ]] && die "${fails} tests failed on ${EPYTHON}"
-
- # we actually need to clean this up manually before running the test
- # suite again...
- chmod -R u+rwX "${T}"/absl_testing || die
- rm -rf "${T}"/absl_testing || die
-}