summaryrefslogtreecommitdiff
path: root/dev-python/absl-py/absl-py-0.2.2-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-12 06:32:46 +0100
commit28e3d252dc8ac8a5635206dfefe1cfe05058d1db (patch)
treee75bce604750fb72e53ed3684059e2e5d2094509 /dev-python/absl-py/absl-py-0.2.2-r1.ebuild
parentf625b9919a60a30f1bd860f7d1b2eac183ced593 (diff)
gentoo resync : 12.08.2018
Diffstat (limited to 'dev-python/absl-py/absl-py-0.2.2-r1.ebuild')
-rw-r--r--dev-python/absl-py/absl-py-0.2.2-r1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/absl-py/absl-py-0.2.2-r1.ebuild b/dev-python/absl-py/absl-py-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..e9071928b72a
--- /dev/null
+++ b/dev-python/absl-py/absl-py-0.2.2-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+inherit distutils-r1
+
+DESCRIPTION="Abseil Python Common Libraries"
+HOMEPAGE="https://github.com/abseil/abseil-py"
+SRC_URI="https://github.com/abseil/abseil-py/archive/pypi-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/abseil-py-pypi-v${PV}"