summaryrefslogtreecommitdiff
path: root/dev-python/aadict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/aadict
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/aadict')
-rw-r--r--dev-python/aadict/Manifest3
-rw-r--r--dev-python/aadict/aadict-0.2.3.ebuild30
-rw-r--r--dev-python/aadict/metadata.xml16
3 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/aadict/Manifest b/dev-python/aadict/Manifest
new file mode 100644
index 000000000000..ebc81db10cc5
--- /dev/null
+++ b/dev-python/aadict/Manifest
@@ -0,0 +1,3 @@
+DIST aadict-0.2.3.tar.gz 16511 BLAKE2B ab9450e358fe0339f60f4d6be6445064c67303420e2d4045a21661f8038ad506c8cfe551fef9353404822b1a2824f6eb6461fc783e252ae156f5d76de41c9d3e SHA512 16f3ff59f41d5dd1f9504ed11d660636766758332a0317544253daef9d76f2fdfc654add6346ad809e56e2be51c1f19a645c1047ef01e1e4aee8db24afcab113
+EBUILD aadict-0.2.3.ebuild 715 BLAKE2B 2685cf91922276ddad88530e638a8b19c3f156de12003c4828fe6b284bbfc4de7bbb802ef3e0c7cb22d31eacb81b71ac81b336787b8895324aab2fc3b713fb38 SHA512 7c47abf57b6b51b7b8275fab57061626eccf7747eb04fee5b20f81c728c6a820bd932d6706f3d7d6f2d2bc31acb617864027f705b7f275016df4a50d24f26bda
+MISC metadata.xml 503 BLAKE2B b917d303ed73f424328952a01daa1302e3dae2876f1e5fea0c0cf6792e2fe0957a873062cd9f7b5e2fa5e27ba56c3d98d06e112e2d20da0508fc6876f5d16933 SHA512 31dd3aecd967835f84c7f6449b1adaf8c8e6cbd2f8513dcb2b0d3193c97b8588f58fd881f27c7b766e072cead538f6327492977d2d03ae54654756b04ab9b5fc
diff --git a/dev-python/aadict/aadict-0.2.3.ebuild b/dev-python/aadict/aadict-0.2.3.ebuild
new file mode 100644
index 000000000000..f5f468b1d0db
--- /dev/null
+++ b/dev-python/aadict/aadict-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An auto-attribute dict (and a couple of other useful dict functions)"
+HOMEPAGE="https://github.com/metagriffin/aadict https://pypi.org/project/aadict/"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.6.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}
diff --git a/dev-python/aadict/metadata.xml b/dev-python/aadict/metadata.xml
new file mode 100644
index 000000000000..ee0f9630bccc
--- /dev/null
+++ b/dev-python/aadict/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">aadict</remote-id>
+ <maintainer status="unknown">
+ <email>mg.pypi@uberdev.org</email>
+ <name>metagriffin</name>
+ </maintainer>
+ <remote-id type="github">metagriffin/aadict</remote-id>
+ </upstream>
+</pkgmetadata>