summaryrefslogtreecommitdiff
path: root/dev-python/aadict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/aadict
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/aadict')
-rw-r--r--dev-python/aadict/Manifest4
-rw-r--r--dev-python/aadict/aadict-0.2.3.ebuild30
-rw-r--r--dev-python/aadict/metadata.xml16
3 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/aadict/Manifest b/dev-python/aadict/Manifest
new file mode 100644
index 000000000000..41937cac0e46
--- /dev/null
+++ b/dev-python/aadict/Manifest
@@ -0,0 +1,4 @@
+DIST aadict-0.2.3.tar.gz 16511 SHA256 a77328ac55dbb5735da99441870251befe135f687ab707a7a178561363b27704 SHA512 16f3ff59f41d5dd1f9504ed11d660636766758332a0317544253daef9d76f2fdfc654add6346ad809e56e2be51c1f19a645c1047ef01e1e4aee8db24afcab113 WHIRLPOOL d6923d762cf858955cfec7d8bb806dac425ba5a01565c81a0f6970a0e71bee2ee4397c4bc1ed25f0cd123174962903d175ee9c2c2a615e2a461b8a53ccd170c1
+EBUILD aadict-0.2.3.ebuild 717 SHA256 fe9b1dcb0fcf55ea61b3498dcdec5897ee7500e0ebd2b0a842ed118d982af457 SHA512 ad5037d1ec869864ecc805a600a139d064e1a4f2afcbd1398d1bad9e6ff0ddd66ff649f1ab8ab44c163fec14d2eb92ee47c0cbd50a41eedc2ebcfa27d452492e WHIRLPOOL 5431ebca7b16dd7364403787b914f9be6c881d3422aa72f066241e6746b6c279b2bd70b55c20ccbad1d37c0708f9db73ba71e2742c1332dbac01a10eb33c82f9
+MISC ChangeLog 2366 SHA256 ae42b3d9b341215e96a4b6f438cc0bb4b455068aa79efd92ee10e98369e5860a SHA512 ac7fad7737b2a93fdfd58e504e17f314f84188f1e462b59ed5fc94ecb8aa5965a936037a4d2f69afe12e03a5f230860af7ee5b0133d413601d04aa452dd4b1ef WHIRLPOOL e577c7867a18c31482f5640b4fb1340ae354f0515c8e214f18c945bd33cd9c2c530cf887daa2add94a397e512d86db08fe9974c61293de9d82549a3c1bd955b4
+MISC metadata.xml 503 SHA256 bb90b121a4218ef285ea1a147be9181548e8f40158e53f887f162344e615507d SHA512 31dd3aecd967835f84c7f6449b1adaf8c8e6cbd2f8513dcb2b0d3193c97b8588f58fd881f27c7b766e072cead538f6327492977d2d03ae54654756b04ab9b5fc WHIRLPOOL 0ad969819a47eab006537a7bda95256e3d3edf1ed85ad42ea38b4a2f74b77cf2813f4471f7b7f3310e87981f55914d9e17bcf8edd0b320ac7fda53c4cd25640a
diff --git a/dev-python/aadict/aadict-0.2.3.ebuild b/dev-python/aadict/aadict-0.2.3.ebuild
new file mode 100644
index 000000000000..6b3efc9f648c
--- /dev/null
+++ b/dev-python/aadict/aadict-0.2.3.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="An auto-attribute dict (and a couple of other useful dict functions)"
+HOMEPAGE="https://github.com/metagriffin/aadict http://pypi.python.org/pypi/aadict"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ >=dev-python/six-1.6.0[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/nose-1.3.0[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ nosetests --verbose || die
+}
diff --git a/dev-python/aadict/metadata.xml b/dev-python/aadict/metadata.xml
new file mode 100644
index 000000000000..ee0f9630bccc
--- /dev/null
+++ b/dev-python/aadict/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">aadict</remote-id>
+ <maintainer status="unknown">
+ <email>mg.pypi@uberdev.org</email>
+ <name>metagriffin</name>
+ </maintainer>
+ <remote-id type="github">metagriffin/aadict</remote-id>
+ </upstream>
+</pkgmetadata>