summaryrefslogtreecommitdiff
path: root/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild')
-rw-r--r--dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild b/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild
new file mode 100644
index 000000000000..db921ba1591e
--- /dev/null
+++ b/dev-python/SaltTesting/SaltTesting-2018.9.21.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit eutils distutils-r1
+
+DESCRIPTION="Required testing tools needed in the several Salt Stack projects"
+HOMEPAGE="https://saltstack.com/community/"
+
+if [[ ${PV} == *9999* ]]; then
+ EGIT_REPO_URI="https://github.com/saltstack/salt-testing.git"
+ EGIT_BRANCH="develop"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/saltstack/salt-testing/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ S="${WORKDIR}/salt-testing-${PV}"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND="
+ dev-python/psutil[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.4.2[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+PATCHES=(
+ "${FILESDIR}/SaltTesting-2018.9.21-python37.patch"
+)