summaryrefslogtreecommitdiff
path: root/dev-python/Pyro4
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-17 13:54:39 +0100
commitfe7238eca1d510cb096bf290978af72ba6607930 (patch)
tree564be9d3b7f3c9537d08b9b6a75fb119777c36f3 /dev-python/Pyro4
parent403387a1bc2a2d98e75bf1474b21ae379b88aab2 (diff)
gentoo auto-resync : 17:10:2022 - 13:54:39
Diffstat (limited to 'dev-python/Pyro4')
-rw-r--r--dev-python/Pyro4/Manifest2
-rw-r--r--dev-python/Pyro4/Pyro4-4.82-r1.ebuild60
-rw-r--r--dev-python/Pyro4/Pyro4-4.82.ebuild55
3 files changed, 61 insertions, 56 deletions
diff --git a/dev-python/Pyro4/Manifest b/dev-python/Pyro4/Manifest
index 95c7d050f8bb..6d69b284e1a1 100644
--- a/dev-python/Pyro4/Manifest
+++ b/dev-python/Pyro4/Manifest
@@ -1,3 +1,3 @@
DIST Pyro4-4.82.tar.gz 516110 BLAKE2B ecd7b5cf1469896acfec1db92d99784aa316db5cadbb7fc595a5f9916ac705619d070771549fb8ba7379a7395e4449eabcfc84aa131d4b23b587b7467f4bf196 SHA512 f5916ce37ec52d8cd23bece79325480140621ac8412febb4877a32b1ce54502ef17d20bf591dc30eb20e9619741548b30a78165937d5e69e8d1911d95a23b1e1
-EBUILD Pyro4-4.82.ebuild 1251 BLAKE2B 7e14e212a8350b04f35174e1c7e9b8d3852c8462b0e306a88777b6e0f82306504ecf26f06173ad06a6c0b41838476e819c860e6528bb21b6c59ae11a51ef3754 SHA512 11e1063dcd0a51ffd52a809e459749bd404e7fd6278e805818c109a6e55495aa461b80fdc6099288bab79e679b6dc8c1a48dac9aa72526c3e3d43c2c20ee6ac6
+EBUILD Pyro4-4.82-r1.ebuild 1573 BLAKE2B ffd1493b5c4926a09413082af300688ee93a0797dabb119f28b7141d39d154260f0f2b54cc55fc20f3a15b54b3a0bc90c0d5afbb37cea3d69bd8afa8bbaed475 SHA512 7bc74b4a27c8d25178cec6bf2e3a36d252b33a97e285f92959ed2416727c56bf3cf800b44c5818ffda5fec6cc2e5430e02aba0fbe46815122ad92533576ecdf1
MISC metadata.xml 384 BLAKE2B e0dcf58b7db6287f6912e1ce549f52fb269eeac53def37ff75b8c30957c02eaef506a44bc15c3fdfdf01c2607e803b8706cc3be6b50585383f30edcd8c3cebf6 SHA512 9f4ed623a9e07d84fd61b3eccf65d80c883265b3de24d79b888c5d880498325dd268e4e5390f60ed67b19101e072276b1d7eb80724bf7a0cd6713fc20d374e33
diff --git a/dev-python/Pyro4/Pyro4-4.82-r1.ebuild b/dev-python/Pyro4/Pyro4-4.82-r1.ebuild
new file mode 100644
index 000000000000..8f0ca7c2f4dd
--- /dev/null
+++ b/dev-python/Pyro4/Pyro4-4.82-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Distributed object middleware for Python (RPC)"
+HOMEPAGE="
+ https://github.com/irmen/Pyro4/
+ https://pypi.org/project/Pyro4/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ppc x86"
+IUSE="doc examples"
+
+RDEPEND="
+ >=dev-python/serpent-1.27[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/dill-0.2.6[${PYTHON_USEDEP}]
+ >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/PyroTests/test_naming.py
+ tests/PyroTests/test_naming2.py::OfflineNameServerTests::testStartNSfunc
+ tests/PyroTests/test_naming2.py::OfflineNameServerTestsDbmStorage::testStartNSfunc
+ tests/PyroTests/test_naming2.py::OfflineNameServerTestsSqlStorage::testStartNSfunc
+ tests/PyroTests/test_serialize.py::SerializeTests_dill::testSerCoreOffline
+ tests/PyroTests/test_serialize.py::SerializeTests_dill::testSerializeDumpsAndDumpsCall
+ tests/PyroTests/test_socket.py::TestSocketutil::testBroadcast
+ tests/PyroTests/test_socket.py::TestSocketutil::testGetIP
+ )
+
+ cd tests/PyroTests || die
+ epytest
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/. )
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/Pyro4/Pyro4-4.82.ebuild b/dev-python/Pyro4/Pyro4-4.82.ebuild
deleted file mode 100644
index ee8e259935ab..000000000000
--- a/dev-python/Pyro4/Pyro4-4.82.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{8..10} )
-inherit distutils-r1
-
-DESCRIPTION="Distributed object middleware for Python (RPC)"
-HOMEPAGE="https://pypi.org/project/Pyro4/
- https://github.com/irmen/Pyro4"
-SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm64 ppc x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- >=dev-python/serpent-1.27[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- >=dev-python/cloudpickle-1.2.1[${PYTHON_USEDEP}]
- >=dev-python/dill-0.2.6[${PYTHON_USEDEP}]
- >=dev-python/msgpack-0.5.2[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- # Disable tests requiring network connection.
- rm tests/PyroTests/test_naming.py || die
- sed \
- -e "s/testStartNSfunc/_&/" \
- -i tests/PyroTests/test_naming2.py || die
-
- sed \
- -e "s/testBroadcast/_&/" \
- -e "s/testGetIP/_&/" \
- -i tests/PyroTests/test_socket.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- use doc && HTML_DOCS=( docs/. )
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}