summaryrefslogtreecommitdiff
path: root/dev-python/PySDL2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 15:07:44 +0100
commitc9ac6938788ee1708e7c900f8f78e9037aea1ca1 (patch)
tree7775fcc8916726b2e7a58d7a251dee69292d231f /dev-python/PySDL2
parent23fb10c075a74a6504647a16c3e06a6378e208c8 (diff)
gentoo auto-resync : 29:07:2022 - 15:07:44
Diffstat (limited to 'dev-python/PySDL2')
-rw-r--r--dev-python/PySDL2/Manifest2
-rw-r--r--dev-python/PySDL2/PySDL2-0.9.13.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/PySDL2/Manifest b/dev-python/PySDL2/Manifest
index 70e2802f2043..baf3ae98e16a 100644
--- a/dev-python/PySDL2/Manifest
+++ b/dev-python/PySDL2/Manifest
@@ -1,5 +1,7 @@
DIST PySDL2-0.9.11.tar.gz 736026 BLAKE2B ebf5a98958681cc61155aeffdb67ca9d1aeef8143ca876b63772ce95b7bf23cc5708a01cfa83d3128d4fe20c2b714bf2f1e7dc64454c7d063590c55cfc236f24 SHA512 4e3383ef64f4f164d60a69a5a2c6ea153269b45661c9bba988d4c44a5cce7195cec0d29384d1855e9c9d507af2608bc808b9885449aea61c5ee51fc2d4f4af6f
DIST PySDL2-0.9.12.tar.gz 741668 BLAKE2B 82f1f63f0b637981a8e98966f34d721495764630f9f0f95e0f6fd4c428d8adf0a31c540f0dcc36da24f073b3485cdb4987e0deb79d7df484ed05bad93c17a2ed SHA512 e4dd5b11a8e1082751bc45b9a18c1c3f7ff977091a35c35965f93b1946f634ea096ba94088404153c712c42cf3b4a8876c9ae05496def51b296be55c31b3b59b
+DIST PySDL2-0.9.13.tar.gz 754811 BLAKE2B fe9d3fb32cac104303d67741c3b9e0d78d3d03198ed512464bbdf5bc487a5f4c9a92aafb100c53c02d8be87bb107034f67ebb72294ad67cc0a8b42ab7a678a31 SHA512 f866e7ed35e3ccfbb5b98f797e87d5b20c6f7dadbc3396b297cbb6c2d83a7f3290fde63940a4d8f190e40a4a9269d2df9efc1932d9578d3df1617e5fcbe6ecad
EBUILD PySDL2-0.9.11.ebuild 1506 BLAKE2B 1184acac5ab3f83abf120f10dcd35b6c5dc4885cd2da3a4d035035a47e5ee0b2887e777abbf1ec43cc4335e45488811ecd485663b510f71358a77ec634d1bac0 SHA512 1f6b324a64caf9a709c6b69c3a100dcdc6f8539f777dbb2ddd5391ef69f60708ecca340847c3acbbddb824449d6e6aaa1709f0fa05f67388d3265f97d31b0071
EBUILD PySDL2-0.9.12.ebuild 1674 BLAKE2B 560e1c7c68233d4f794ccfb2d1e69aeba29141212f1e8c52d00825bd58aad79b256b52829128746fcdae45d8e7c0553758c70ec59f62b284fc53a65a56591c10 SHA512 5cc4fe30254fefe9d0d44e6623086a4ff058646bbb5636063586807125671782b44b961ef503338521de7d5637ca7a2fd82decf41d530fe435101321b18ec40b
+EBUILD PySDL2-0.9.13.ebuild 1674 BLAKE2B 560e1c7c68233d4f794ccfb2d1e69aeba29141212f1e8c52d00825bd58aad79b256b52829128746fcdae45d8e7c0553758c70ec59f62b284fc53a65a56591c10 SHA512 5cc4fe30254fefe9d0d44e6623086a4ff058646bbb5636063586807125671782b44b961ef503338521de7d5637ca7a2fd82decf41d530fe435101321b18ec40b
MISC metadata.xml 450 BLAKE2B f92f2f7529e3a09d18c88a51f78ed520d7b4756a99776d70bb7ad4e452ae6cd9a67560ebfaafcacbd73e945282fc28ecdb48d54b2c2eb5b18d3f944401650349 SHA512 de7f757b195170ee865e34dcc214d0a57912e50631291045c485f58ba05fa87b7fc57878333021c7b9d3f8609e9afa4190f4c4062fb7a8136498875aecee615c
diff --git a/dev-python/PySDL2/PySDL2-0.9.13.ebuild b/dev-python/PySDL2/PySDL2-0.9.13.ebuild
new file mode 100644
index 000000000000..e6dabf07cdbd
--- /dev/null
+++ b/dev-python/PySDL2/PySDL2-0.9.13.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python (ctypes) bindings for SDL2 libraries"
+HOMEPAGE="
+ https://github.com/py-sdl/py-sdl2/
+ https://pypi.org/project/PySDL2/
+"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( public-domain CC0-1.0 ZLIB )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# Optional deps:
+# - dev-python/numpy,
+# - dev-python/pillow,
+# - media-libs/sdl2-* (loaded dynamically via ctypes).
+#
+# If a reverse dependency needs the specific module, it should
+# explicitly depend on the optional module in question. You also
+# probably need to explicitly require some media-libs/libsdl2 flags.
+RDEPEND="media-libs/libsdl2"
+
+# Require all of SDL2 libraries and at least the most common subsystems
+# for better test coverage.
+DEPEND="
+ test? (
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ media-libs/libsdl2[joystick,sound,video]
+ media-libs/sdl2-gfx
+ media-libs/sdl2-image[gif,jpeg,png,tiff,webp]
+ || (
+ media-libs/sdl2-mixer[flac]
+ media-libs/sdl2-mixer[midi]
+ media-libs/sdl2-mixer[mod]
+ media-libs/sdl2-mixer[mp3]
+ media-libs/sdl2-mixer[opus]
+ )
+ media-libs/sdl2-ttf
+ )"
+
+EPYTEST_DESELECT=(
+ # Both tests fail and seem machine-dependent?
+ sdl2/test/sdlttf_test.py::test_TTF_SetFontSize
+ sdl2/test/sdlttf_test.py::test_TTF_SetFontSizeDPI
+)
+
+distutils_enable_tests pytest
+
+src_test() {
+ # from .travis.yml
+ local -x SDL_VIDEODRIVER=dummy
+ local -x SDL_AUDIODRIVER=dummy
+ local -x SDL_RENDER_DRIVER=software
+
+ distutils-r1_src_test
+}