summaryrefslogtreecommitdiff
path: root/dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-14 17:40:19 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-14 17:40:19 +0100
commitb23b1d43c4a10df85088f74d98a914917f114538 (patch)
tree6dc0ff9e7ed8d4efbb297e572d216fb9c85efbb7 /dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild
parent57aee2868b3c58313cc276d2871eacfb8c95c020 (diff)
gentoo auto-resync : 14:10:2023 - 17:40:19
Diffstat (limited to 'dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild')
-rw-r--r--dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild b/dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild
new file mode 100644
index 000000000000..c7f0d5a6d814
--- /dev/null
+++ b/dev-python/PyQt6-sip/PyQt6-sip-13.6.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYPI_PN=${PN/-/_}
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="sip module support for PyQt6"
+HOMEPAGE="https://www.riverbankcomputing.com/software/sip/"
+
+LICENSE="|| ( GPL-2 GPL-3 SIP )"
+SLOT="0"
+KEYWORDS="~amd64"