summaryrefslogtreecommitdiff
path: root/dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-04-25 23:59:45 +0100
commit6243676c91946098c06d42bc87b5eb99aac40bf0 (patch)
treee6de308ba22148b4898b67b049c7f017ece8fea2 /dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild
parentb987a550f067c3da93b0664cf1fdc8a624c0aa38 (diff)
gentoo auto-resync : 25:04:2024 - 23:59:45
Diffstat (limited to 'dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild')
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild
new file mode 100644
index 000000000000..363aa24ff3ba
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.16.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://github.com/Python-PyQt/PyQt-builder/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ >=dev-python/setuptools-scm-8[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # don't install prebuilt DLLs
+ rm -r pyqtbuild/bundle/dlls || die
+}