summaryrefslogtreecommitdiff
path: root/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-29 13:42:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-29 13:42:04 +0000
commit5cb89cb9de4cdd1a06010c3d45748c33afab2408 (patch)
tree26bd27474f2e409c4d36a9864299f2e4cc4f87f2 /dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
parent8d12644534a171c85dd84343b976054ad30faa6d (diff)
gentoo auto-resync : 29:12:2023 - 13:42:04
Diffstat (limited to 'dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild')
-rw-r--r--dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild b/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
new file mode 100644
index 000000000000..b4257018de20
--- /dev/null
+++ b/dev-python/Opcodes/Opcodes-0.3.14-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..12} )
+inherit distutils-r1
+
+CommitId=0f7c7d63f5e13ce5a89d9acc3934f1b6e247ec1f
+
+DESCRIPTION="Opcodes Project"
+HOMEPAGE="
+ https://pypi.org/project/Opcodes/
+"
+SRC_URI="https://github.com/Maratyszcza/${PN}/archive/${CommitId}.tar.gz
+ -> ${P}.gh.tar.gz"
+S="${WORKDIR}"/${PN}-${CommitId}
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64"
+RESTRICT="test" # depends on an old version of werkzeug
+
+RDEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=readme.rst
+
+distutils_enable_sphinx sphinx \
+ dev-python/sphinx-bootstrap-theme