summaryrefslogtreecommitdiff
path: root/dev-python/HeapDict
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/HeapDict
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/HeapDict')
-rw-r--r--dev-python/HeapDict/HeapDict-1.0.0.ebuild20
-rw-r--r--dev-python/HeapDict/Manifest3
-rw-r--r--dev-python/HeapDict/metadata.xml15
3 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/HeapDict/HeapDict-1.0.0.ebuild b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
new file mode 100644
index 000000000000..3a4e5471a901
--- /dev/null
+++ b/dev-python/HeapDict/HeapDict-1.0.0.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Heap with decrease-key and increase-key operations"
+HOMEPAGE="http://stutzbachenterprises.com/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
diff --git a/dev-python/HeapDict/Manifest b/dev-python/HeapDict/Manifest
new file mode 100644
index 000000000000..7334996515a9
--- /dev/null
+++ b/dev-python/HeapDict/Manifest
@@ -0,0 +1,3 @@
+DIST HeapDict-1.0.0.tar.gz 7713 BLAKE2B 19aedc2e7a61c74b93aa8883603520bc6ffeebae4ac4c4a4003023bf6b1c65ff55f9ef571a3e61ea92620a18eed281ad603a61e1df4f03a8811096e9f0964ab9 SHA512 1210acd3a6f3e091132d8b87963ec46c81d3141e1788c2a127fe348a9052d73225036aeabffc6a2089c7811b8571a43477055b746df6b128a645123862076bb5
+EBUILD HeapDict-1.0.0.ebuild 483 BLAKE2B 6e2683fa789c69bb3931bd6a81a09cbe7b9f060e487d42a830ee4b0765c631763d143138b994f7d26bed4e6f6e83e2463cdbd861878b1629b1e80901ade62d5b SHA512 419d1b412c29b7d1c8806475c493a28b59bdca2611fdd63a82d5bb8d60b94741623117531fe3ff0b94a392ada71dc00db202c2904a767a54d9cbf4929b5053eb
+MISC metadata.xml 522 BLAKE2B a4feb2dcf86b348f8e07a76c82261db274d46668bcddd36677e8896eeb993badf321987a592ddc37bd85a9f4e237bd12c6df1cbe289fe3b3354b37352ab70786 SHA512 aca6d43cfb9d6eee3f47079bc26874f12e95f8efbdd4bdcf2685b65374b5a6500de2f12d065bdbce12b82496b931c3c00ff9ffb7aa1e040c11ea033e12304be8
diff --git a/dev-python/HeapDict/metadata.xml b/dev-python/HeapDict/metadata.xml
new file mode 100644
index 000000000000..a59ab0464cae
--- /dev/null
+++ b/dev-python/HeapDict/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <longdescription>
+ heapdict implements the MutableMapping ABC, meaning it works pretty much like a regular Python dict.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">HeapDict</remote-id>
+ <remote-id type="github">dask/zict</remote-id>
+ </upstream>
+</pkgmetadata>