summaryrefslogtreecommitdiff
path: root/dev-python/GridDataFormats
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-22 08:45:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-22 08:45:32 +0100
commit940cec7afea0fff03b206c62a512335e6f9d2d00 (patch)
tree719c138f497dce562bd86f32bec882f5a4220459 /dev-python/GridDataFormats
parent752353adf60f88b9de2c3c752a871b9f907e2acb (diff)
gentoo auto-resync : 22:10:2023 - 08:45:32
Diffstat (limited to 'dev-python/GridDataFormats')
-rw-r--r--dev-python/GridDataFormats/GridDataFormats-1.0.2.ebuild29
-rw-r--r--dev-python/GridDataFormats/Manifest2
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/GridDataFormats/GridDataFormats-1.0.2.ebuild b/dev-python/GridDataFormats/GridDataFormats-1.0.2.ebuild
new file mode 100644
index 000000000000..17991fb8df1a
--- /dev/null
+++ b/dev-python/GridDataFormats/GridDataFormats-1.0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Reading and writing of data on regular grids in Python"
+HOMEPAGE="
+ https://pypi.org/project/GridDataFormats/
+ https://github.com/MDAnalysis/GridDataFormats/
+"
+
+SLOT="0"
+LICENSE="LGPL-3"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/mrcfile[${PYTHON_USEDEP}]
+ >=dev-python/numpy-1.21[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/GridDataFormats/Manifest b/dev-python/GridDataFormats/Manifest
index 009c7ba20ef3..dec48db005a8 100644
--- a/dev-python/GridDataFormats/Manifest
+++ b/dev-python/GridDataFormats/Manifest
@@ -1,3 +1,5 @@
DIST GridDataFormats-1.0.1.tar.gz 2155370 BLAKE2B 8bf5ce65cefdcf490b75212bca8831957769118fbad7fdce42b5634ed67a1f5d4ac454f7429b984bafd89f5bc883fff1bca9dc71f529794cdd585e186e41e063 SHA512 2cfb8c50b4d17fa978924a0e65ae27f6e125bd1055bfdc9096ea35511f4c2a8a16f6bd9c652b9130fbdd66d4d464d8074b14f47c175f98df94c02fe973a0107b
+DIST GridDataFormats-1.0.2.tar.gz 2158614 BLAKE2B b5cb9a8abe78a52a8b3f3a053d15a3f9eed73ede3a3a5ce1c29390efa654ebe0e79d42042241028c46a6ed8511fde0f4f2a576c58ab2003c58bfb86d9ae1cbda SHA512 e0f316cb5352dee2b0902122007bf78ba8605109b21ea9c21a02f1bd7649ffb1d5115459077aa33ceb6464c310e750e512835acbcb4ce2256ea6be6e5b10c098
EBUILD GridDataFormats-1.0.1.ebuild 641 BLAKE2B 01b81fd205262f4e0cb6f65af90d184c3c1abc8bcdec575355fc818d10118544b4c94c93df68d39a2c4653b86f48ae089fe3a0380bdf8223b758a70314545802 SHA512 a2d9b12c5d3a9c29fb1dbaf92559563853a9d735662dce508cffbc82bd4f7f46ab423638a7a03bb468b05b7ba807a51841b5f977456257e4c90cd4bd7b7ae563
+EBUILD GridDataFormats-1.0.2.ebuild 641 BLAKE2B 35e4035e5c0601eb4eb9e1ca3e0572b272e9c0e00851ed45de77b2af2a5e075f406dbd89dc57860c235583e4905d481f854a47540b8ae1ef86d427ff993b0567 SHA512 7afd0437f1d2c9622a33899260136450a48f5db0c91b3bad5d4bf24601cbb60b99fd4341a3b640b2aaee653cc85018fff65a7dd9b5fca2002c468ab8f3820ad1
MISC metadata.xml 608 BLAKE2B 25b3e613ce6776ecc00b7ab3e65ba253be7715f167b37d4fc4d625b035e8d24706cd56bc14f2f0cac2b3f4da6b84c8bcd2b219914490b9e3bc9fab0cbbc2ddfc SHA512 48ca119e78978f100a3212a59d716d49766e6bd523813c5395d05f705f1258e1899183d52faabfef95162b82ccfa08b5b771c1a00c53d7c42a54aaa97eb9ae52