summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-24.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-03-14 06:47:04 +0000
commit404b23b9395fafe5c40a1fd4d859c6cd17b4a646 (patch)
tree789ba7b9b17a99ad3ccbf05a131086babface825 /dev-python/Faker/Faker-24.2.0.ebuild
parent633a3741c9483bd63e8c29b276d2af636ec8b390 (diff)
gentoo auto-resync : 14:03:2024 - 06:47:03
Diffstat (limited to 'dev-python/Faker/Faker-24.2.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-24.2.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-24.2.0.ebuild b/dev-python/Faker/Faker-24.2.0.ebuild
new file mode 100644
index 000000000000..4a85c701f3c8
--- /dev/null
+++ b/dev-python/Faker/Faker-24.2.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}