summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-18.6.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-04 11:28:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-04 11:28:04 +0100
commit47a1d2f184696819152c003a600beb058fbc4420 (patch)
treea85ea2840d8bb2bfaea292c4e2f363b663cc1ea1 /dev-python/Faker/Faker-18.6.2.ebuild
parent42564959cad787b3e82c0ebd8a8a6a59958e1370 (diff)
gentoo auto-resync : 04:05:2023 - 11:28:04
Diffstat (limited to 'dev-python/Faker/Faker-18.6.2.ebuild')
-rw-r--r--dev-python/Faker/Faker-18.6.2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-18.6.2.ebuild b/dev-python/Faker/Faker-18.6.2.ebuild
new file mode 100644
index 000000000000..f1e5f5fe409a
--- /dev/null
+++ b/dev-python/Faker/Faker-18.6.2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest