summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-18.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-21 12:39:53 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-21 12:39:53 +0000
commit9d5a20176934a287f9e0970722062db5242d30fa (patch)
tree38fe74a0c66384df6a03863d36d16c0a1f2c804e /dev-python/Faker/Faker-18.2.0.ebuild
parent0464b87d8be9fcf33aebbd906bc0d3a65c953cff (diff)
gentoo auto-resync : 21:03:2023 - 12:39:52
Diffstat (limited to 'dev-python/Faker/Faker-18.2.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-18.2.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-18.2.0.ebuild b/dev-python/Faker/Faker-18.2.0.ebuild
new file mode 100644
index 000000000000..f1e5f5fe409a
--- /dev/null
+++ b/dev-python/Faker/Faker-18.2.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest