summaryrefslogtreecommitdiff
path: root/dev-python/Faker/Faker-16.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-18 11:56:49 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-18 11:56:49 +0000
commit95b557bc48bb734c288bac87dcfe98b8ae3d1cdb (patch)
treec5ffde10d5eed804daa50794c905d6b228af7177 /dev-python/Faker/Faker-16.6.0.ebuild
parent3b34ca9eec2676e6fe530f34e463f52308a11441 (diff)
gentoo auto-resync : 18:01:2023 - 11:56:49
Diffstat (limited to 'dev-python/Faker/Faker-16.6.0.ebuild')
-rw-r--r--dev-python/Faker/Faker-16.6.0.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-16.6.0.ebuild b/dev-python/Faker/Faker-16.6.0.ebuild
new file mode 100644
index 000000000000..82c8c94c9551
--- /dev/null
+++ b/dev-python/Faker/Faker-16.6.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest