summaryrefslogtreecommitdiff
path: root/dev-python/BitVector/BitVector-3.4.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-29 18:01:47 +0000
commitceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (patch)
tree9f47ee47c31a0f13f9496879cd88a1042550aa81 /dev-python/BitVector/BitVector-3.4.9.ebuild
parent53cba99042fa967e2a93da9f8db806fe2d035543 (diff)
gentoo (leap year) resync : 29.02.2020
Diffstat (limited to 'dev-python/BitVector/BitVector-3.4.9.ebuild')
-rw-r--r--dev-python/BitVector/BitVector-3.4.9.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/BitVector/BitVector-3.4.9.ebuild b/dev-python/BitVector/BitVector-3.4.9.ebuild
new file mode 100644
index 000000000000..d996f372ccd0
--- /dev/null
+++ b/dev-python/BitVector/BitVector-3.4.9.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+inherit distutils-r1
+
+DESCRIPTION="A pure-Python memory-efficient packed representation for bit arrays"
+HOMEPAGE="https://engineering.purdue.edu/kak/dist/ https://pypi.org/project/BitVector/"
+SRC_URI="https://engineering.purdue.edu/kak/dist/${P}.tar.gz"
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND=""
+
+python_test() {
+ "${PYTHON}" TestBitVector/Test.py || die "Tests fail with ${EPYTHON}"
+}