summaryrefslogtreecommitdiff
path: root/dev-python/Babel
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:18:26 +0100
commit6c30cc2d5bd48ddbdbe8d75544899cd5dbfcaba4 (patch)
tree6ef7f6e1d48141a5da904d788b906da5bba4b697 /dev-python/Babel
parent62f82c107c3904ac6917ece47301d2999c7dd90e (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/Babel')
-rw-r--r--dev-python/Babel/Babel-2.5.0.ebuild4
-rw-r--r--dev-python/Babel/Babel-2.5.3-r1.ebuild8
-rw-r--r--dev-python/Babel/Babel-2.5.3.ebuild2
-rw-r--r--dev-python/Babel/Babel-2.6.0.ebuild49
-rw-r--r--dev-python/Babel/Manifest10
-rw-r--r--dev-python/Babel/metadata.xml2
6 files changed, 65 insertions, 10 deletions
diff --git a/dev-python/Babel/Babel-2.5.0.ebuild b/dev-python/Babel/Babel-2.5.0.ebuild
index 7c0fc25e2672..f764c52dc983 100644
--- a/dev-python/Babel/Babel-2.5.0.ebuild
+++ b/dev-python/Babel/Babel-2.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -9,7 +9,7 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ https://pypi.org/project/Babel/"
+HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
diff --git a/dev-python/Babel/Babel-2.5.3-r1.ebuild b/dev-python/Babel/Babel-2.5.3-r1.ebuild
index 254db65acaff..bbc2fbebb31f 100644
--- a/dev-python/Babel/Babel-2.5.3-r1.ebuild
+++ b/dev-python/Babel/Babel-2.5.3-r1.ebuild
@@ -9,12 +9,12 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ https://pypi.org/project/Babel/"
+HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
IUSE="doc test"
RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
@@ -34,9 +34,11 @@ python_prepare_all() {
}
python_test() {
+ local -x TZ=UTC
+
# Create implementation-specific datadir for tests.
cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
- py.test || die
+ py.test -vv || die
}
python_compile_all() {
diff --git a/dev-python/Babel/Babel-2.5.3.ebuild b/dev-python/Babel/Babel-2.5.3.ebuild
index 760a35531d9b..f056341ba246 100644
--- a/dev-python/Babel/Babel-2.5.3.ebuild
+++ b/dev-python/Babel/Babel-2.5.3.ebuild
@@ -9,7 +9,7 @@ PYTHON_REQ_USE="threads(+)"
inherit distutils-r1
DESCRIPTION="Collection of tools for internationalizing Python applications"
-HOMEPAGE="http://babel.edgewall.org/ https://pypi.org/project/Babel/"
+HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
diff --git a/dev-python/Babel/Babel-2.6.0.ebuild b/dev-python/Babel/Babel-2.6.0.ebuild
new file mode 100644
index 000000000000..aaf13989c173
--- /dev/null
+++ b/dev-python/Babel/Babel-2.6.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{4,5,6}} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of tools for internationalizing Python applications"
+HOMEPAGE="http://babel.pocoo.org/ https://pypi.org/project/Babel/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~x64-solaris"
+IUSE="doc test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ # Make the tests use implementation-specific datadir,
+ # because they try to write in it.
+ sed -e '/datadir =/s:os\.path\.dirname(__file__):os.environ["BUILD_DIR"]:' \
+ -i tests/messages/test_frontend.py || die
+ sed -e '/^intersphinx_mapping/,+3d' -i docs/conf.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x TZ=UTC
+
+ # Create implementation-specific datadir for tests.
+ cp -R -l tests/messages/data "${BUILD_DIR}"/ || die
+ py.test -vv || die
+}
+
+python_compile_all() {
+ if use doc; then
+ emake -C docs html
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
diff --git a/dev-python/Babel/Manifest b/dev-python/Babel/Manifest
index 170ee153c970..abfa44fcc470 100644
--- a/dev-python/Babel/Manifest
+++ b/dev-python/Babel/Manifest
@@ -1,6 +1,8 @@
DIST Babel-2.5.0.tar.gz 6612353 BLAKE2B 85268f0226f1db019fb906da0dfbbc6b6aa199ab491e9d767c932fb5ca77cb6d86328ebaa9c6eb61fb8d28c8e566babd435cdcee9b900c3c680d0dfb49c2bcac SHA512 b24b74121695e0068fb28a6294d4b5b2065e94dcd62ca0d70c8fde3a00cb5ff111480505594460989c6f67a75935f55e153b1b493f917317d2c5ee0f0d7921fc
DIST Babel-2.5.3.tar.gz 6611941 BLAKE2B 99b71642b00a853fea844220c0ce5ef2fe425906cbdd1618e31f39b60d16382d54ff5e00c493153eee2be8894edc8c96e57fc2703620db5bafcf7b7a4f1b72ef SHA512 1a41f69141da9f66e27110e7a1a5955f76d8ae9353ff7e54182c5bb6ca16e8b4799031e4df1049af54de513da9f101e171e4312b2e7775f2cab9116d5b50c0fb
-EBUILD Babel-2.5.0.ebuild 1474 BLAKE2B fa19a905009e0ed2b3c69a8b941aeca328e923de63b21dc1424c45a28828bf500a99d5f3680032ced396d73114014b3e8c0d52d0e5fee648e9793c102aa3585f SHA512 e57278aa11d989c671a01836089d8642a9ebf02085133ad664a6532a439259c181a69177a3e2063196d27d65056d07bb754aa4416aea60142808dcf2eca36a8d
-EBUILD Babel-2.5.3-r1.ebuild 1521 BLAKE2B ba4f44bf1300c927d7bb1ebe8ecb45beba57a4e29b5d4d64b83f2ff9e6f693d65bcb74be3ab9daa45bdefa136e6e1b57467fd89daa4778ae5cd7ddcf84e7249f SHA512 8cc4bc5b40e2e5282342133d1fcce3b0af35d6c377f2e1bc9224c6458757d50c6b1649c714d978c32ea1d41eaf78cf90328d703b915a752d01eba4ff8cdb7225
-EBUILD Babel-2.5.3.ebuild 1475 BLAKE2B 6accc1bb679517e07e9872ccddde886e584753a34025b62c95ccedb2dcad5005535bcfac3027b33c3ca987594a4c799cb8c8f7eeb4bfacd6d282fcbaca38e2a7 SHA512 22cd5ca8483f03efa51f8ba7127df0890ad24da1ffbee9ddf56c50e3064e4f8d78ac1244b377ea6ff023c04d4e5f10e8d11554be5c245d28faa52a5228495730
-MISC metadata.xml 715 BLAKE2B 8bdd049fad7b20c0fed9c6cb5d468468421fdd83404d73f9972bea9e74cb1c7a7bc8a268aa444b62990c61da5a6441491b31a1b02600abef1f693b385ac2862e SHA512 7623e3246442997195e57ee74ca3a60803a90787486a930d4952d06521e0ca295216f8824f9b781f27c48c9e454fc9b0c8a4a9c10de9339a27c043b97acf1cee
+DIST Babel-2.6.0.tar.gz 7960433 BLAKE2B 0edc3b3391eb3d479eae9a223668af96e1ec47b84b13d0bb66c0e1772dc5de8321ee06f0d0dfeb6c9364a724286d0ee50a3ab4c2ea789894057fca39bb11dc46 SHA512 a87f26c25f1e48a64d1e7ee112bc0c325a6268e0e716a81cb6814a53f0add8f3d579babd2ba064f160298ebe3ac9711aa5d28f112582ee287767b6ed8427b6e0
+EBUILD Babel-2.5.0.ebuild 1471 BLAKE2B c9c9e00923f2b27400a7898c0bb69025840bf058569f52220699cd468980f17132faebca0b5710f9fd797fd4857d49d8d5768ef05d4768908b7dbaa41245e36a SHA512 eb9807bb50fe367a92cff89826189f29135c08006e77aff84d0228ecf6e772011050148aa4e655636206aaca7ba7281818ee448a7d457084f38c8ac7bfd7c511
+EBUILD Babel-2.5.3-r1.ebuild 1539 BLAKE2B 6842ee24132b2aa410561db4fb283deaab493d07b9300c4e619090ac9aac0a4e43142d0c966af537814f3a4a2478e9587c43bb2005f3402c3f2ee56cdc6417c0 SHA512 2964da6282dcb0b301be414d89c3e665dc573a8d6574590f1b941d69f250ee29ee2669fc9685f2f624727df6910f61b660495ab8cc82a88de7359b32564ef0f7
+EBUILD Babel-2.5.3.ebuild 1472 BLAKE2B 130348dc2960f5ce61e4708069826ef73fb18c0e24117e514a0329843448037fd0534cf649c18af2fe6b04452b1b777c5b64bff37cc23c071d4a7b56827674a2 SHA512 6a23c39ef56ec915b73128eafefb895fa19a1743159a5578d24ad77cd291328127324a95b5687483f9a2cb51aab982bc117d9b4fe6940f170bf4383af15b0f33
+EBUILD Babel-2.6.0.ebuild 1477 BLAKE2B 7175cd34d55957aca7504228796b4cea67fcff1eae1a5bc3273ec4f1f63e4d054a17eccff7c23d04d2731a426b49b3a4d483bdb6c46ee19f3843f9988fb723e0 SHA512 4a4fb579eb2cb0be946fa770705b0cf968229beeef367fbc4dde652604d7fbaaa411abcec59b5df213fb4503c0b3349d31cdb28e9a65efc3925c71abf507be5b
+MISC metadata.xml 839 BLAKE2B d9916ce88ce8436bb28d15300e78013e1c9e0f88f385a369c0ad6840f0fe81ad136052a3c257cef50a2fd86500bcde2b652ad0ed664f95d6affa4ccc8770445b SHA512 3688c1488c552b84c685d0aeb6251aea4f9d41be3db3aeb226291655107e1332df13445545b3742587e133de7468a40f22ca53fa67fd8d2e0db570069498654f
diff --git a/dev-python/Babel/metadata.xml b/dev-python/Babel/metadata.xml
index a498ec71cd62..4f8d2872452f 100644
--- a/dev-python/Babel/metadata.xml
+++ b/dev-python/Babel/metadata.xml
@@ -16,5 +16,7 @@
<stabilize-allarches/>
<upstream>
<remote-id type="pypi">Babel</remote-id>
+ <remote-id type="github">python-babel/babel</remote-id>
+ <bugs-to>https://github.com/python-babel/babel/issues</bugs-to>
</upstream>
</pkgmetadata>