summaryrefslogtreecommitdiff
path: root/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-24 23:59:54 +0000
commit401101f9c8077911929d3f2b60a37098460a5d89 (patch)
treec2bef4719f6787550f0916aeaa8f4f403a9296af /dev-python/Arpeggio/Arpeggio-2.0.0.ebuild
parent4cbcc855382a06088e2f016f62cafdbcb7e40665 (diff)
gentoo resync : 25.03.2022
Diffstat (limited to 'dev-python/Arpeggio/Arpeggio-2.0.0.ebuild')
-rw-r--r--dev-python/Arpeggio/Arpeggio-2.0.0.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild b/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild
new file mode 100644
index 000000000000..e25d2baeb0cc
--- /dev/null
+++ b/dev-python/Arpeggio/Arpeggio-2.0.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Parser interpreter based on PEG grammars"
+HOMEPAGE="https://pypi.org/project/Arpeggio/ https://github.com/textX/Arpeggio"
+SRC_URI="
+ https://github.com/textX/Arpeggio/archive/${PV}.tar.gz -> ${P}.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+DEPEND="
+ test? (
+ dev-python/memory_profiler[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i -e '/^setup_requires/,/^[^[:space:]]/d' setup.cfg || die
+ distutils-r1_python_prepare_all
+}