summaryrefslogtreecommitdiff
path: root/dev-python/APScheduler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /dev-python/APScheduler
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'dev-python/APScheduler')
-rw-r--r--dev-python/APScheduler/APScheduler-3.1.0.ebuild38
-rw-r--r--dev-python/APScheduler/APScheduler-3.2.0.ebuild38
-rw-r--r--dev-python/APScheduler/APScheduler-3.3.1.ebuild36
-rw-r--r--dev-python/APScheduler/APScheduler-3.5.3.ebuild69
-rw-r--r--dev-python/APScheduler/Manifest8
5 files changed, 106 insertions, 83 deletions
diff --git a/dev-python/APScheduler/APScheduler-3.1.0.ebuild b/dev-python/APScheduler/APScheduler-3.1.0.ebuild
deleted file mode 100644
index 5413a75c8508..000000000000
--- a/dev-python/APScheduler/APScheduler-3.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="In-process task scheduler with Cron-like capabilities"
-HOMEPAGE="https://github.com/agronholm/apscheduler"
-SRC_URI="mirror://pypi/A/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-1.2[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-capturelog[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed -i -e /setuptools_scm/d setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # 3 known failures due to caplog.set_level not existing
- py.test || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/APScheduler/APScheduler-3.2.0.ebuild b/dev-python/APScheduler/APScheduler-3.2.0.ebuild
deleted file mode 100644
index 5413a75c8508..000000000000
--- a/dev-python/APScheduler/APScheduler-3.2.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
-
-inherit distutils-r1
-
-DESCRIPTION="In-process task scheduler with Cron-like capabilities"
-HOMEPAGE="https://github.com/agronholm/apscheduler"
-SRC_URI="mirror://pypi/A/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-
-RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/setuptools[${PYTHON_USEDEP}]
- >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/tzlocal-1.2[${PYTHON_USEDEP}]
- virtual/python-funcsigs[${PYTHON_USEDEP}]
- virtual/python-futures[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-capturelog[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed -i -e /setuptools_scm/d setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- # 3 known failures due to caplog.set_level not existing
- py.test || die "Testing failed with ${EPYTHON}"
-}
diff --git a/dev-python/APScheduler/APScheduler-3.3.1.ebuild b/dev-python/APScheduler/APScheduler-3.3.1.ebuild
index c4f2cbbc9d71..b6e4912c7f02 100644
--- a/dev-python/APScheduler/APScheduler-3.3.1.ebuild
+++ b/dev-python/APScheduler/APScheduler-3.3.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,11 +24,43 @@ RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
DEPEND="${RDEPEND}
test? (
dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-capturelog[${PYTHON_USEDEP}]
)"
+# Tests that are known to fail (some may be triggered by network-sandbox).
+test_failures=(
+ test_add_class_method_job
+ test_add_instance_method_job
+ test_add_job_conflicting_id
+ test_asyncio_executor_shutdown
+ test_get_all_jobs
+ test_get_next_run_time
+ test_get_pending_jobs
+ test_get_pending_jobs_subsecond_difference
+ test_lookup_job
+ test_lookup_nonexistent_job
+ test_one_job_fails_to_load
+ test_remove_all_jobs
+ test_remove_job
+ test_remove_nonexistent_job
+ test_repr_mongodbjobstore
+ test_repr_redisjobstore
+ test_repr_zookeeperjobstore
+ test_run_coroutine_job
+ test_run_coroutine_job_tornado
+ test_update_job
+ test_update_job_clear_next_runtime
+ test_update_job_next_runtime
+ test_update_job_nonexistent_job
+ test_zookeeper_client_keep_open
+ test_zookeeper_client_ref
+)
+
python_prepare_all() {
sed -i -e /setuptools_scm/d setup.py || die
+ while read -r -d ''; do
+ sed -Ee "s:$(echo "${test_failures[@]}"| sed 's: :|:g'):_\\0:" -i "${REPLY}" || die
+ done < <(grep -rElZ "$(echo "${test_failures[@]}"| sed 's: :|:g')" "${S}")
+
distutils-r1_python_prepare_all
}
diff --git a/dev-python/APScheduler/APScheduler-3.5.3.ebuild b/dev-python/APScheduler/APScheduler-3.5.3.ebuild
new file mode 100644
index 000000000000..b43883c56e5a
--- /dev/null
+++ b/dev-python/APScheduler/APScheduler-3.5.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="In-process task scheduler with Cron-like capabilities"
+HOMEPAGE="https://github.com/agronholm/apscheduler"
+SRC_URI="mirror://pypi/A/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tzlocal-1.2[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]
+ virtual/python-futures[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+# Tests that are known to fail (some may be triggered by network-sandbox).
+test_failures=(
+ test_add_class_method_job
+ test_add_instance_method_job
+ test_add_job_conflicting_id
+ test_asyncio_executor_shutdown
+ test_get_all_jobs
+ test_get_next_run_time
+ test_get_pending_jobs
+ test_get_pending_jobs_subsecond_difference
+ test_lookup_job
+ test_lookup_nonexistent_job
+ test_one_job_fails_to_load
+ test_remove_all_jobs
+ test_remove_job
+ test_remove_nonexistent_job
+ test_repr_mongodbjobstore
+ test_repr_redisjobstore
+ test_repr_zookeeperjobstore
+ test_run_coroutine_job
+ test_run_coroutine_job_tornado
+ test_update_job
+ test_update_job_clear_next_runtime
+ test_update_job_next_runtime
+ test_update_job_nonexistent_job
+ test_zookeeper_client_keep_open
+ test_zookeeper_client_ref
+)
+
+python_prepare_all() {
+ sed -i -e /setuptools_scm/d setup.py || die
+ while read -r -d ''; do
+ sed -Ee "s:$(echo "${test_failures[@]}"| sed 's: :|:g'):_\\0:" -i "${REPLY}" || die
+ done < <(grep -rElZ "$(echo "${test_failures[@]}"| sed 's: :|:g')" "${S}")
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ py.test || die "Testing failed with ${EPYTHON}"
+}
diff --git a/dev-python/APScheduler/Manifest b/dev-python/APScheduler/Manifest
index 98880575f36f..200d99ffcd41 100644
--- a/dev-python/APScheduler/Manifest
+++ b/dev-python/APScheduler/Manifest
@@ -1,7 +1,5 @@
-DIST APScheduler-3.1.0.tar.gz 79124 BLAKE2B fefa9e273259eff7f2ce6889064e5fa6333d6eb76ce0fde65a3e3d41a44b81466d9329cee211c8641ee543802b0691bf0a89c55701adb6f6a301c3c28543878c SHA512 8f8b1a997dffd8ebc090113f3edd6ba1c18514e2583e1bca52ed54b28c7965d146e082fa64de968f44b18b39aa5ead7e3114e3e049102aaab35c52245f37497c
-DIST APScheduler-3.2.0.tar.gz 80946 BLAKE2B 4c8e74b35fb0167b8238792c1064e73570d385f9a149ae6c222fda596fdab61d5c1a641e4aae83b799dc4a21df7772538cea15e34d5b229e9ffe96e7e56ac482 SHA512 451e03e01a5b01126c8ab21acb6b053099271056372a5a66cf302a6aac02f5d4d9b033a0551d1029d82dee32b74db01518fc21c8bc718bbd38cf6417f68234e0
DIST APScheduler-3.3.1.tar.gz 84198 BLAKE2B 8706c68dc2b8097d4656da00b62b298ad2b0cb94079bd32b08c0c3316f8317bf299d513ef120822d40b938aff4c49aaa9a1beef9d91e554f02413407b2848711 SHA512 af861bff47f881200d97551d60a6d3210c9bf864fa83a37da7fbff31d24e9fce5d64d965ffefe6f8678320ad6dcf86dbdc65b611991b14fd8edd18efbf7e6bbd
-EBUILD APScheduler-3.1.0.ebuild 1004 BLAKE2B 2fc441b0c1c1c7342298b983b4dfeda0e3e6969b1431ac9ff2a6ee5ad6d93abc49e1ff91ff260ddcd56bdf75bcf4c8d831a65e1ec6ce7da83c94a91d6c6211e2 SHA512 854a5800224f12e1ed84aaddd9a7c3f2ad67009831b5aa064f7d83da9d4095593b4337b9fb5b1760b12540f4715a779e559cd561e33f1e2ed294f4d5a20da39d
-EBUILD APScheduler-3.2.0.ebuild 1004 BLAKE2B 2fc441b0c1c1c7342298b983b4dfeda0e3e6969b1431ac9ff2a6ee5ad6d93abc49e1ff91ff260ddcd56bdf75bcf4c8d831a65e1ec6ce7da83c94a91d6c6211e2 SHA512 854a5800224f12e1ed84aaddd9a7c3f2ad67009831b5aa064f7d83da9d4095593b4337b9fb5b1760b12540f4715a779e559cd561e33f1e2ed294f4d5a20da39d
-EBUILD APScheduler-3.3.1.ebuild 1008 BLAKE2B 06d01c4caf9f0e717b78e5db0208018b945471d867eeef2fc3389df47080ed794b42905856d78742ff7b9f6de4c6ce165eac15ac6ad709f25cecf2e2f873b4c5 SHA512 3a0db6b5b627db05ccdd3f5ee8c9fafb20a323c81e1defd1c8f675fe6199982ce699314326a078a22e71c749c6bde547c75fbcac7bfdd5dd7e622dc872e63fc8
+DIST APScheduler-3.5.3.tar.gz 95527 BLAKE2B 3d1bb49a497781d017e2fbd47176186f6449650500c57a141a114f6c610081b9d85553793f9c9f00422d3a299c26c292ab667cfe3866c381bcbf39161133b615 SHA512 dd3e98d0f474511851bdc109a1c65f7f97d221f95d086603d12b3f280285460234724369f05816e1754d58d94adadbec0deb8a0fa63fcd6531914d4a1f4fb3fc
+EBUILD APScheduler-3.3.1.ebuild 1921 BLAKE2B cfc62442a7cb41087b85be59cefdca484010a3612c006a63e0fe9665b6a39b3a8487f5f021281e28411cc0042787dd89d05c53b3587d3396d69555607a94367d SHA512 8e0c06b3a765594db9113cb9f1ed4149b8baeab44d1dc3fca975d6e8b145eb1505e87a358e57914c3d29efc81cfa5e16c2ecf2015a03ed81b9f4999bc381c992
+EBUILD APScheduler-3.5.3.ebuild 1864 BLAKE2B 2c5e849cdfff471a3119dc1ac01528777d6c12ef78917f0f05fbcdf0c096dfd30981154ce4840964e4c9fd3cc6fff452a07bc740087b74edf969a9bafeff4152 SHA512 747094045c38d2813a816d9b8e5c045eb53112a8933b8ba2d07d98651be76d2626f1a1b910cd33dd4e425bb78199fdbd45cf512cb6aa10c037d962b163308905
MISC metadata.xml 353 BLAKE2B e0c141ff0ac5a9f98c3b55871de97976f15324b722420a8def45a053b2fdd0b992c44bd6d1c4824c479700871951423ff13f921043a5dd8770ae73a279deac9b SHA512 48d42b0d3fd5ab07ecbd8554cef11d06bf5d7616e777d6e76103699f305f9aee7bd8618294d5548a62815a621bd4fe6ac4d32c008b79ac7f7334d6a29a261008