summaryrefslogtreecommitdiff
path: root/dev-python/3to2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/3to2
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/3to2')
-rw-r--r--dev-python/3to2/3to2-1.1.1-r1.ebuild34
-rw-r--r--dev-python/3to2/3to2-1.1.1.ebuild24
-rw-r--r--dev-python/3to2/Manifest6
-rw-r--r--dev-python/3to2/metadata.xml15
4 files changed, 79 insertions, 0 deletions
diff --git a/dev-python/3to2/3to2-1.1.1-r1.ebuild b/dev-python/3to2/3to2-1.1.1-r1.ebuild
new file mode 100644
index 000000000000..d45b2e5c5e74
--- /dev/null
+++ b/dev-python/3to2/3to2-1.1.1-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
+HOMEPAGE="https://pypi.python.org/pypi/3to2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+python_prepare() {
+ # https://bitbucket.org/amentajo/lib3to2/issues/50/testsuite-fails-with-new-python-35
+ # Remove failing test
+ sed -i -e "/test_argument_unpacking/a \\ return"\
+ lib3to2/tests/test_print.py || die
+ sed -i -e "s/Exception, err/Exception as err/" lib3to2/build.py || die
+ distutils-r1_python_prepare_all
+
+}
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # the standard test runner fails to properly return failure
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/3to2/3to2-1.1.1.ebuild b/dev-python/3to2/3to2-1.1.1.ebuild
new file mode 100644
index 000000000000..445f48e5af2c
--- /dev/null
+++ b/dev-python/3to2/3to2-1.1.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+inherit distutils-r1
+
+DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
+HOMEPAGE="https://pypi.python.org/pypi/3to2"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.zip"
+
+LICENSE="Apache-1.1"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+DEPEND="app-arch/unzip"
+
+python_test() {
+ cd "${BUILD_DIR}"/lib || die
+ # the standard test runner fails to properly return failure
+ "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/3to2/Manifest b/dev-python/3to2/Manifest
new file mode 100644
index 000000000000..70509c79c131
--- /dev/null
+++ b/dev-python/3to2/Manifest
@@ -0,0 +1,6 @@
+DIST 3to2-1.1.1.zip 78779 SHA256 fef50b2b881ef743f269946e1090b77567b71bb9a9ce64b7f8e699b562ff685c SHA512 7580f174409420556f89ae78eba07cc95b95aee9d062586d0862bd41980ae31bf4ac82a43855e160eec745fcdd3b4aff614f68e77da1bfc5f9f404413cab1492 WHIRLPOOL 39b8b8c2da3f759c93488888d4ccf9eae123302a5b7ae5861fdf4ad1be75a31e57dc752e382cb3ebc49b46921ab12d95d7837948e78c3c96dd98f4701805bf14
+EBUILD 3to2-1.1.1-r1.ebuild 944 SHA256 c48c7ee47b42c7c051942990186fd9ac68b12e40490e2b77dcc95d15a586ff6a SHA512 1e8299a4e04147da3eefc2d9e49d1b0857a80ac06649dc8563e98227e094404752abe173790ad05a99e1ed6a66c28cfacb3acf46499d52141cb3a56bc6be5e7c WHIRLPOOL 0d071b0369ed33867507b4c91bac8a2fa4dd0dc63f7d08f22a17b706fbc493088452abb0c10b23d62ac15e7b0acd3e04e18a0d28c7787ebe478154ea5d44caee
+EBUILD 3to2-1.1.1.ebuild 605 SHA256 58575969666d60d53f504316017a06805e45d9d341f0233050dc569d32b9f34a SHA512 1b274c5b141392b2eca6b3f93a95f66f0a46a4034a31e7d6c942e4a8ba30943030e61ce7d072b4b173773b2f68f74b08d28d38fc35d5888128fe6e3190407d3a WHIRLPOOL ba20d4fb4721f57ff664a7d57bbe3dc240d489d05f63505a13968adf203ef6406af8f3d71aa0d09a3af40e4ff32fe5bcc0bb9143b3fab63f8ad573117338e286
+MISC ChangeLog 3145 SHA256 c9f314f178afa0395e0fa31abc21359e2769dd37a5c7e245d80367a39f35fcd7 SHA512 9201b5646db8a937f6adc8b16a11959415f70f1f5cee722fc0c6dd269981c4dba12fcf29f73970fec3abbfa4a7f6be1b2b896e051b7019dc25a02b8381bb0640 WHIRLPOOL cbda80d0744c7c9626394820da7d666e366da5730e588a08a93367ed7ecfb70a18f196831125988077b04eb8ff3b24769441af4a61f50bd65b6564600df9e51b
+MISC ChangeLog-2015 1474 SHA256 5b7d3cc18baac8a78f1e8f1697f010c112489bb883bf4a3d85925233eecf8ff7 SHA512 8a2d38fded416368cd91297608feedde586aa7493391705cdba2bdc71437766b12f74501111468c8dd5a256366127a3874af51be8cd99948acde73f320bc25cc WHIRLPOOL 569dcb0e2f3660724643391cb9da078f8de93812083cf006d5f110fd2d5f74ee131f7caa273718a9b017148e4315032e80ab75f4a3897a23fcb3a43f32f808b3
+MISC metadata.xml 433 SHA256 5b06e8f65d106eb0248a907b38ddd172fb48ad17526c075388c61613fdf6ec27 SHA512 fbf01ed6fe0bfdf49ba985e62e8694d7152129e0d46a3701fe39dd11ed7d48641efaea848694a271f39b9ae7e6b805b0ac535945cf33d455e0745d1f66ad3c04 WHIRLPOOL 5c1f912c75e56150610c1b25304e2ad1e34ad7d5c1ee03ee93eba29abf5ae91f89b80143f293b6f0ad37dfce111b0832b15c7a3a70081fab39476bca3972837d
diff --git a/dev-python/3to2/metadata.xml b/dev-python/3to2/metadata.xml
new file mode 100644
index 000000000000..57a9d13fae65
--- /dev/null
+++ b/dev-python/3to2/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>chutzpah@gentoo.org</email>
+ <name>Patrick McLean</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">3to2</remote-id>
+ </upstream>
+</pkgmetadata>