summaryrefslogtreecommitdiff
path: root/dev-python/3to2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/3to2
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/3to2')
-rw-r--r--dev-python/3to2/3to2-1.1.1-r1.ebuild6
-rw-r--r--dev-python/3to2/Manifest2
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-python/3to2/3to2-1.1.1-r1.ebuild b/dev-python/3to2/3to2-1.1.1-r1.ebuild
index 901ee6302dd2..8f3da8e9d470 100644
--- a/dev-python/3to2/3to2-1.1.1-r1.ebuild
+++ b/dev-python/3to2/3to2-1.1.1-r1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
@@ -17,7 +17,7 @@ IUSE=""
BDEPEND="app-arch/unzip"
-python_prepare() {
+python_prepare_all() {
# https://bitbucket.org/amentajo/lib3to2/issues/50/testsuite-fails-with-new-python-35
# Remove failing test
sed -i -e "/test_argument_unpacking/a \\ return"\
@@ -30,5 +30,5 @@ python_prepare() {
python_test() {
cd "${BUILD_DIR}"/lib || die
# the standard test runner fails to properly return failure
- "${EPYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/3to2/Manifest b/dev-python/3to2/Manifest
index 0aeca12696c0..026f3de0f423 100644
--- a/dev-python/3to2/Manifest
+++ b/dev-python/3to2/Manifest
@@ -1,3 +1,3 @@
DIST 3to2-1.1.1.zip 78779 BLAKE2B 441e74bd06017c84bd382c32513d84f42b8bc35f46aeb62ec1e3f5b9876573e0a76f6e04f4ca529175761af6f29e10ee0c4d4114ff0bcafb066d2d6344b1d885 SHA512 7580f174409420556f89ae78eba07cc95b95aee9d062586d0862bd41980ae31bf4ac82a43855e160eec745fcdd3b4aff614f68e77da1bfc5f9f404413cab1492
-EBUILD 3to2-1.1.1-r1.ebuild 928 BLAKE2B b4da96c2b768ecfa7c648a7daed11485d040dec625e580749d32d91d303da08cbfb891c388cad17e112d3deed5faf37de70a850cd6a7a6d6f65f2c7b7b2ab379 SHA512 83588fa92f03ea7cd85023fb19e25b11b6a37266da7dc6b55d06ce4dd7d22637cc48118f5cfb1c4b7faf5f0b53bc499cc125d09cd2f742036cd507998e1b7946
+EBUILD 3to2-1.1.1-r1.ebuild 936 BLAKE2B dd79c87d50a66a308aa92cd9d779a9f92b5d0f3870f2d441dd473f2c35bfc379a0afada607936ea48a03cea8290479664ea6d28d80a6f4f6bf6123437464567a SHA512 2b16f4d30ab8dd269b9cdcb1de48741c5543e9ae8836ecf72cfa49b2f5aae3a1ca97ad9ef5056711795c2d00e2b5639e54ff6258a81615fff8d0bb1dd2de82b0
MISC metadata.xml 433 BLAKE2B 4f1b66cebd6b0b9f083d0896f702cc2f882d0d05a28634fad2d83af9802ccdfeb237e8d1eddee71c5a18663ede779085c28c81c3586b4ccfa2274c5dd8a9e1cc SHA512 fbf01ed6fe0bfdf49ba985e62e8694d7152129e0d46a3701fe39dd11ed7d48641efaea848694a271f39b9ae7e6b805b0ac535945cf33d455e0745d1f66ad3c04