summaryrefslogtreecommitdiff
path: root/dev-python/3to2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-02 21:45:28 +0100
commit2018227e9344edb9da15fc6a4a8298086cc2aa77 (patch)
treec18e1c09e605e94e2a1e93345ad25746cc9e14b9 /dev-python/3to2
parent6f8038813c460b4f0572d5ef595cdfa94af3a94d (diff)
gentoo resync : 02.06.2019
Diffstat (limited to 'dev-python/3to2')
-rw-r--r--dev-python/3to2/3to2-1.1.1-r1.ebuild10
-rw-r--r--dev-python/3to2/Manifest2
2 files changed, 6 insertions, 6 deletions
diff --git a/dev-python/3to2/3to2-1.1.1-r1.ebuild b/dev-python/3to2/3to2-1.1.1-r1.ebuild
index 4f850563c501..9297c84877eb 100644
--- a/dev-python/3to2/3to2-1.1.1-r1.ebuild
+++ b/dev-python/3to2/3to2-1.1.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-PYTHON_COMPAT=( python{2_7,3_5,3_6} )
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
inherit distutils-r1
DESCRIPTION="Tool to refactor valid 3.x syntax into valid 2.x syntax"
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="app-arch/unzip"
+BDEPEND="app-arch/unzip"
python_prepare() {
# https://bitbucket.org/amentajo/lib3to2/issues/50/testsuite-fails-with-new-python-35
@@ -23,12 +23,12 @@ python_prepare() {
sed -i -e "/test_argument_unpacking/a \\ return"\
lib3to2/tests/test_print.py || die
sed -i -e "s/Exception, err/Exception as err/" lib3to2/build.py || die
- distutils-r1_python_prepare_all
+ distutils-r1_python_prepare_all
}
python_test() {
cd "${BUILD_DIR}"/lib || die
# the standard test runner fails to properly return failure
- "${PYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
+ "${EPYTHON}" -m unittest discover || die "Tests fail with ${EPYTHON}"
}
diff --git a/dev-python/3to2/Manifest b/dev-python/3to2/Manifest
index 49138d765b65..f3274ae25b9e 100644
--- a/dev-python/3to2/Manifest
+++ b/dev-python/3to2/Manifest
@@ -1,4 +1,4 @@
DIST 3to2-1.1.1.zip 78779 BLAKE2B 441e74bd06017c84bd382c32513d84f42b8bc35f46aeb62ec1e3f5b9876573e0a76f6e04f4ca529175761af6f29e10ee0c4d4114ff0bcafb066d2d6344b1d885 SHA512 7580f174409420556f89ae78eba07cc95b95aee9d062586d0862bd41980ae31bf4ac82a43855e160eec745fcdd3b4aff614f68e77da1bfc5f9f404413cab1492
-EBUILD 3to2-1.1.1-r1.ebuild 932 BLAKE2B 27f414a3567d5c27c86ced5559854a9149be18d7f827edbd26604cfba9bf4c02ce7f8eec0eca5e18731a6a4e1baa3fa4f658cab2f79feda3e6acadf8e5ec66f7 SHA512 46239f8cd96b23c026db9146aa5aaaa6be90cec19aa2e39d16692fe74d5afd312656b604d97c199a474f961a7fc3dba075b8789c86ecac96930360e6c22d64db
+EBUILD 3to2-1.1.1-r1.ebuild 938 BLAKE2B e82f635615cce525c61ea754a63a90c088818d4f38b7d291e227f7c1544f2ac4445e4964ef6279d06d5cbefa9de32c9c650091f3f5af2259d7e1da837731c55a SHA512 c7803360442d06e5404e486a33620960cf8b3e99216aaecce4cba770828e2c044ad382bf609aed513e1058c19a36cd54ad7a29e98b176704754f741000792618
EBUILD 3to2-1.1.1.ebuild 595 BLAKE2B c0223c8bda0a43b0a31311a1971345a5fb73b05516699fb2d446a118fee8dab1cfcd3329cbf26a8b4ad3876fe899a0e58acc1725fae2210288158ad5a1dc9e85 SHA512 1e58c8e8ccfcf84091295f186be9db8a41c9ba011702e9de44aea636e230b6419a65b3a3d5e29949ca0cdae80ac4865816e98bf882f7024802ee6bd5101c8f44
MISC metadata.xml 433 BLAKE2B 4f1b66cebd6b0b9f083d0896f702cc2f882d0d05a28634fad2d83af9802ccdfeb237e8d1eddee71c5a18663ede779085c28c81c3586b4ccfa2274c5dd8a9e1cc SHA512 fbf01ed6fe0bfdf49ba985e62e8694d7152129e0d46a3701fe39dd11ed7d48641efaea848694a271f39b9ae7e6b805b0ac535945cf33d455e0745d1f66ad3c04