summaryrefslogtreecommitdiff
path: root/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-php/suhosin/suhosin-0.9.38-r1.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-php/suhosin/suhosin-0.9.38-r1.ebuild')
-rw-r--r--dev-php/suhosin/suhosin-0.9.38-r1.ebuild56
1 files changed, 0 insertions, 56 deletions
diff --git a/dev-php/suhosin/suhosin-0.9.38-r1.ebuild b/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
deleted file mode 100644
index 3f2162f1716d..000000000000
--- a/dev-php/suhosin/suhosin-0.9.38-r1.ebuild
+++ /dev/null
@@ -1,56 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI="6"
-
-PHP_EXT_NAME="suhosin"
-PHP_EXT_INI="no"
-PHP_EXT_ZENDEXT="no"
-USE_PHP="php5-6"
-
-inherit php-ext-source-r3
-
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-
-DESCRIPTION="Suhosin is an advanced protection system for PHP installations"
-HOMEPAGE="https://www.suhosin.org/"
-SRC_URI="https://download.suhosin.org/${P}.tar.gz"
-LICENSE="PHP-3.01"
-SLOT="0"
-IUSE=""
-
-for target in ${USE_PHP}; do
- slot=${target/php}
- slot=${slot/-/.}
- PHPUSEDEPEND="${PHPUSEDEPEND}
- php_targets_${target}? ( dev-lang/php:${slot}[unicode] )"
-done
-
-DEPEND="${PHPUSEDEPEND}"
-RDEPEND="${DEPEND}"
-
-PATCHES=( "${FILESDIR}"/${P}-libcrypt.patch )
-DOCS=( CREDITS )
-
-src_install() {
- php-ext-source-r3_src_install
-
- local slot inifile
- for slot in $(php_get_slots); do
- php_init_slot_env ${slot}
- for inifile in $(php_slot_ini_files "${slot}") ; do
- insinto "${inifile/${PHP_EXT_NAME}.ini/}"
- insopts -m644
- doins "suhosin.ini"
- done
- done
-}
-
-src_test() {
- # Makefile passes a hard-coded -d extension_dir=./modules, we move the lib
- # away from there in src_compile
- for slot in `php_get_slots`; do
- php_init_slot_env ${slot}
- NO_INTERACTION="yes" emake test
- done
-}