summaryrefslogtreecommitdiff
path: root/dev-php/sebastian-environment
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-php/sebastian-environment
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-php/sebastian-environment')
-rw-r--r--dev-php/sebastian-environment/Manifest4
-rw-r--r--dev-php/sebastian-environment/files/autoload.php14
-rw-r--r--dev-php/sebastian-environment/metadata.xml11
-rw-r--r--dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild26
4 files changed, 55 insertions, 0 deletions
diff --git a/dev-php/sebastian-environment/Manifest b/dev-php/sebastian-environment/Manifest
new file mode 100644
index 000000000000..c37dfe89e098
--- /dev/null
+++ b/dev-php/sebastian-environment/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 372 SHA256 8083cd2003811ad2acc3c554d84913178ab1c89074fa06e5899e8598284f5004 SHA512 7fc348367571b5c7409635ec61c2b06f7fea3b640998f93eca87423529ecc4c933cfb5b033152081dd42817e9861d2fdfddcfb5f0d08d51ccf60d5c12f56a76d WHIRLPOOL 666ab8907bfd7872aab2f4bffdaca356440ff4de50ab3e6e203904cd61bf4b21a2d88dbc6e46457d3c2f731c96e3fa3ab06c12a4c62631b4dfd083dc00e0dec7
+DIST sebastian-environment-2.0.0.tar.gz 5607 SHA256 0462a65d901c97056b1ebaadcfebc4b2756c17b7e3fb8504030e49f6cb9a6f00 SHA512 cf91f0a5f057007f318c5d6b11f8a1345b8df35d513c6291c5b725f0874ed301a64d1097c3fac1e6b32533caa96b3f78ac415d99b9b6ef63dc4a303b90d49c88 WHIRLPOOL e7571a56fe7a4e7e5f16027e620a668a3c7e545b8b2374516fe7eb66d0b4bbc829e46ec650ecf85230073e7910e83a382ee102c27fe8f458d0f6e33373f3a155
+EBUILD sebastian-environment-2.0.0.ebuild 665 SHA256 d6c967e7afc2a0a0547278e0a9b1132089fe2142eee8f9bc759ad7b0e5c8d36e SHA512 7dc46e3278b14cfa2fec9d7904f041f6020130f1e96b16bed82ba86f79920a5cccd06d74c315debcaf0b7628c9525744cb5be9138134edd506b6b6493757d53d WHIRLPOOL bc9420949942c52df51057d9ab9beed04dbc885ccf8438da46f5488034271d716581205ebed7069e7d63c2c585b5be2052e7cb37c93a1acb3465436a70786857
+MISC metadata.xml 322 SHA256 34e3655863b8130010ccea2323cb797d39a5b3bba3b7f0085adfa3ef0348f339 SHA512 e345c6459f1c0f795081e2874aa4a4023998d0a0f6b28462468ef89c7cfaf38366671a68d05516e6d0f3e03b0cdfcbe849c1e224f7b1e3a723232c7db32281b6 WHIRLPOOL 2b1ff345241d6b0452f1347fc9eeade46f76894faf411ee1d027ce252ef4ba99ca3042b8903ed1bd45b911e829fc170ee36948d21c837f0f2411198b93bf36aa
diff --git a/dev-php/sebastian-environment/files/autoload.php b/dev-php/sebastian-environment/files/autoload.php
new file mode 100644
index 000000000000..3abd16ee357b
--- /dev/null
+++ b/dev-php/sebastian-environment/files/autoload.php
@@ -0,0 +1,14 @@
+<?php
+/* Autoloader for dev-php/sebastian-environment */
+
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once '/usr/share/php/Fedora/Autoloader/autoload.php';
+}
+
+\Fedora\Autoloader\Autoload::addClassMap(
+ array(
+ 'sebastianbergmann\environment\console' => '/Console.php',
+ 'sebastianbergmann\environment\runtime' => '/Runtime.php',
+ ),
+ __DIR__
+);
diff --git a/dev-php/sebastian-environment/metadata.xml b/dev-php/sebastian-environment/metadata.xml
new file mode 100644
index 000000000000..f5ad6af5af2e
--- /dev/null
+++ b/dev-php/sebastian-environment/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version='1.0' encoding='UTF-8'?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">sebastianbergmann/</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild b/dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild
new file mode 100644
index 000000000000..86bf4b7344f9
--- /dev/null
+++ b/dev-php/sebastian-environment/sebastian-environment-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="${PN/sebastian-//}"
+
+DESCRIPTION="Helps writing PHP code that has runtime-specific execution paths"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Environment
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}