summaryrefslogtreecommitdiff
path: root/dev-php/phptal/phptal-1.3.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-04-28 20:02:04 +0100
commita4e2a46beb5e4858ef27bdedbb0ff6d2ced430ad (patch)
tree852c90a4bf354c30ea66504f70bfab5401fba18d /dev-php/phptal/phptal-1.3.1.ebuild
parent5e8702bcbbed438e6c6cce023e7ef0cc9baa3e02 (diff)
gentoo resync : 28.04.2018
Diffstat (limited to 'dev-php/phptal/phptal-1.3.1.ebuild')
-rw-r--r--dev-php/phptal/phptal-1.3.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-php/phptal/phptal-1.3.1.ebuild b/dev-php/phptal/phptal-1.3.1.ebuild
new file mode 100644
index 000000000000..f5ab86bdfd82
--- /dev/null
+++ b/dev-php/phptal/phptal-1.3.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_LIB_NAME="PHPTAL"
+
+DESCRIPTION="A templating engine for PHP5 that implements Zope Page Templates syntax"
+HOMEPAGE="https://phptal.org/"
+SRC_URI="https://github.com/${PN}/${PHP_LIB_NAME}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-lang/php:*"
+DEPEND="test? ( ${RDEPEND} dev-php/phpunit )"
+
+S="${WORKDIR}/${PHP_LIB_NAME}-${PV}"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/php/${PN}
+ doins -r "classes/${PHP_LIB_NAME}"
+ doins classes/PHPTAL.php tools/phptal_lint.php
+
+ dodoc README.md
+}
+
+src_test() {
+ [[ -z $(locale -a |grep en_GB) ]] && ewarn "Tests require en_GB locale to complete"
+ phpunit || die
+}