summaryrefslogtreecommitdiff
path: root/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild')
-rw-r--r--dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild b/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild
new file mode 100644
index 000000000000..77a6e0f02b05
--- /dev/null
+++ b/dev-php/phpspec-prophecy/phpspec-prophecy-1.10.0.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="7"
+
+MY_PN="prophecy"
+MY_VENDOR="phpspec"
+
+DESCRIPTION="Highly opinionated mocking framework"
+HOMEPAGE="https://github.com/phpspec/prophecy"
+SRC_URI="https://github.com/${MY_VENDOR}/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ <dev-php/doctrine-instantiator-2
+ <dev-php/phpdocumentor-reflection-docblock-6
+ <dev-php/sebastian-comparator-4
+ <dev-php/sebastian-recursion-context-4
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/${MY_VENDOR}/Prophecy
+ doins -r src/Prophecy/*
+ newins "${FILESDIR}/autoload-1.10.0.php" autoload.php
+}