summaryrefslogtreecommitdiff
path: root/dev-php/phpmd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-29 11:38:31 +0100
commit90c88731bd036e5698b281fbc0a5f3aa4c9983ac (patch)
tree83fc5facb6b12be510a37bc3d241cc63e965b13a /dev-php/phpmd
parentfeb0daf81d888e9160f9f94502de09b66f2a63fd (diff)
gentoo resync : 29.06.2020
Diffstat (limited to 'dev-php/phpmd')
-rw-r--r--dev-php/phpmd/Manifest2
-rw-r--r--dev-php/phpmd/phpmd-2.8.2.ebuild38
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-php/phpmd/Manifest b/dev-php/phpmd/Manifest
index 5c6918920320..1f32232adccb 100644
--- a/dev-php/phpmd/Manifest
+++ b/dev-php/phpmd/Manifest
@@ -1,4 +1,6 @@
AUX autoload.php 325 BLAKE2B 73cdf98199c37978e3a82ff70583220bc9a93494ca204d6a9da321b943407db5144ac376c40590a7bf784109633679a267838e9e52889977947395e5ee38528c SHA512 2cbb2349a598c9515cd995b22cb685d4ea6e9e5edc6c0e5ce602f7520c4aa70cc63872c31209720019c424ab188b063aedf7829899882608eafca9c83794d219
DIST phpmd-2.6.0.tar.gz 57496 BLAKE2B 447e1b0a18372abc82746e8f2a47ea0df76fdeea51e7012ea63a0d644f7cd71790a3e354584d18f57bab3e7211f1037ff3f61aff367c3419caa44e77e79d1cbb SHA512 7c81bef8457f28dd40b908f535cf432d65ba6910c54f730b4d9f7a0bffa096653af029701a6ce4bd22910ec69453c5ff22c657100757d7d6eacff2226b597023
+DIST phpmd-2.8.2.tar.gz 68049 BLAKE2B 5135364fd77aa7e56bcbc7cda7b8bff1daf08211ff2a555aadb6f9fd6706d138bd89a3bfdb8b33f15df8746826d2c09435fa1d69109609a2e7b63843ba15e0fc SHA512 7c793181fa954b8c67334c0e0bdbb5bd93244233c404fb8b51ceacb3ede121e7fb66f69d555455fddbf333741a8d8636b85f20884a09988934e128f853f6faaa
EBUILD phpmd-2.6.0.ebuild 1124 BLAKE2B 6e6e34fb5ddb5c00a14c76df601255368822c999ab8756fa35af633e4857759d6fa9d641ef25095bd5bbf703a46fef32d42c0d9e3e5f027e31811d425ce1ccac SHA512 1fe7d91ededcddcdc8b3b8b722be70592ee2f6d2fca08543a62abdc5e6dc7bbfee5cad97774fed9c3394134c230b35a45d2799043da2e609b36e64ae641ebc87
+EBUILD phpmd-2.8.2.ebuild 1121 BLAKE2B 6e0ecb3f10faa0d5c6aa42de1d6c1e68958a5e61aa3a9800c2204134e6d8a0675fdf71999d594b8c1880086d0fd816dd248ba71497243f93c4c1f2723c355c0f SHA512 9d28c9c06b28a7263cb0223e6abc5d77a857b20cff3bdb263230cda907610e70b0a411957acd8f3561d9972b93d754e1b3b39d8481404d3c47123ba3fef988e9
MISC metadata.xml 325 BLAKE2B 80b920bf354b940ca23aaf02297c6ca21ef4d782831c2f4edfba9756c29dc13ed7c74d6d8e58635c0f3915e3c939dc6a4290ce00751965eaabad995b6969fff9 SHA512 d2f6eb6841f0c21aeea3e158ef62388d2cddb3eb4c9a363b211fe232d9b64e4d45d80856986d5293c1d5ad17948648bc606133d28b3001b912ed1fe022ee2432
diff --git a/dev-php/phpmd/phpmd-2.8.2.ebuild b/dev-php/phpmd/phpmd-2.8.2.ebuild
new file mode 100644
index 000000000000..e760429e045b
--- /dev/null
+++ b/dev-php/phpmd/phpmd-2.8.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="PHP mess detector"
+HOMEPAGE="http://www.phpmd.org/"
+
+# The test suite is absent from the release tarballs because
+# the only build system that Composer understands is "cp -r".
+# To obtain the tests, we would need to grab a VCS snapshot.
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[xml]
+ dev-php/phpdepend"
+
+src_install() {
+ dodoc AUTHORS.rst CHANGELOG CONTRIBUTING.md README.rst
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ insinto "/usr/share/${PN}/src"
+ doins -r src/main
+
+ # The executable uses relative include paths, so the one users will
+ # actually run needs to be symlinked into the source tree.
+ exeinto "/usr/share/${PN}/src/bin"
+ doexe "src/bin/${PN}"
+ dosym "../share/${PN}/src/bin/${PN}" "/usr/bin/${PN}"
+}