summaryrefslogtreecommitdiff
path: root/dev-php/phpmd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/phpmd
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/phpmd')
-rw-r--r--dev-php/phpmd/Manifest4
-rw-r--r--dev-php/phpmd/files/autoload.php14
-rw-r--r--dev-php/phpmd/metadata.xml11
-rw-r--r--dev-php/phpmd/phpmd-2.6.0.ebuild38
4 files changed, 67 insertions, 0 deletions
diff --git a/dev-php/phpmd/Manifest b/dev-php/phpmd/Manifest
new file mode 100644
index 000000000000..5c6918920320
--- /dev/null
+++ b/dev-php/phpmd/Manifest
@@ -0,0 +1,4 @@
+AUX autoload.php 325 BLAKE2B 73cdf98199c37978e3a82ff70583220bc9a93494ca204d6a9da321b943407db5144ac376c40590a7bf784109633679a267838e9e52889977947395e5ee38528c SHA512 2cbb2349a598c9515cd995b22cb685d4ea6e9e5edc6c0e5ce602f7520c4aa70cc63872c31209720019c424ab188b063aedf7829899882608eafca9c83794d219
+DIST phpmd-2.6.0.tar.gz 57496 BLAKE2B 447e1b0a18372abc82746e8f2a47ea0df76fdeea51e7012ea63a0d644f7cd71790a3e354584d18f57bab3e7211f1037ff3f61aff367c3419caa44e77e79d1cbb SHA512 7c81bef8457f28dd40b908f535cf432d65ba6910c54f730b4d9f7a0bffa096653af029701a6ce4bd22910ec69453c5ff22c657100757d7d6eacff2226b597023
+EBUILD phpmd-2.6.0.ebuild 1124 BLAKE2B 6e6e34fb5ddb5c00a14c76df601255368822c999ab8756fa35af633e4857759d6fa9d641ef25095bd5bbf703a46fef32d42c0d9e3e5f027e31811d425ce1ccac SHA512 1fe7d91ededcddcdc8b3b8b722be70592ee2f6d2fca08543a62abdc5e6dc7bbfee5cad97774fed9c3394134c230b35a45d2799043da2e609b36e64ae641ebc87
+MISC metadata.xml 325 BLAKE2B 80b920bf354b940ca23aaf02297c6ca21ef4d782831c2f4edfba9756c29dc13ed7c74d6d8e58635c0f3915e3c939dc6a4290ce00751965eaabad995b6969fff9 SHA512 d2f6eb6841f0c21aeea3e158ef62388d2cddb3eb4c9a363b211fe232d9b64e4d45d80856986d5293c1d5ad17948648bc606133d28b3001b912ed1fe022ee2432
diff --git a/dev-php/phpmd/files/autoload.php b/dev-php/phpmd/files/autoload.php
new file mode 100644
index 000000000000..b0fa4764c7ca
--- /dev/null
+++ b/dev-php/phpmd/files/autoload.php
@@ -0,0 +1,14 @@
+<?php
+if (!class_exists('Fedora\\Autoloader\\Autoload', false)) {
+ require_once('/usr/share/php/Fedora/Autoloader/autoload.php');
+}
+
+\Fedora\Autoloader\Autoload::addPsr4(
+ 'PHPMD\\',
+ __DIR__ . '/../src/main/php/PHPMD'
+);
+
+
+\Fedora\Autoloader\Dependencies::required(
+ array('/usr/share/phpdepend/vendor/autoload.php')
+);
diff --git a/dev-php/phpmd/metadata.xml b/dev-php/phpmd/metadata.xml
new file mode 100644
index 000000000000..133c28059f56
--- /dev/null
+++ b/dev-php/phpmd/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">phpmd/phpmd</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-php/phpmd/phpmd-2.6.0.ebuild b/dev-php/phpmd/phpmd-2.6.0.ebuild
new file mode 100644
index 000000000000..dc08acef5020
--- /dev/null
+++ b/dev-php/phpmd/phpmd-2.6.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DESCRIPTION="PHP mess detector"
+HOMEPAGE="http://www.phpmd.org/"
+
+# The test suite is absent from the release tarballs because
+# the only build system that Composer understands is "cp -r".
+# To obtain the tests, we would need to grab a VCS snapshot.
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/php[xml]
+ dev-php/phpdepend"
+
+src_install() {
+ dodoc AUTHORS.rst CHANGELOG CONTRIBUTING.md README.rst
+
+ # The executable will only look for autoload.php in one place, so we
+ # create an (otherwise pointless) vendor directory to house it.
+ insinto "/usr/share/${PN}/vendor"
+ doins "${FILESDIR}/autoload.php"
+
+ insinto "/usr/share/${PN}/src"
+ doins -r src/main
+
+ # The executable uses relative include paths, so the one users will
+ # actually run needs to be symlinked into the source tree.
+ exeinto "/usr/share/${PN}/src/bin"
+ doexe "src/bin/${PN}"
+ dosym "../share/${PN}/src/bin/${PN}" "/usr/bin/${PN}"
+}