summaryrefslogtreecommitdiff
path: root/dev-php/pecl-uploadprogress
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-uploadprogress
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-uploadprogress')
-rw-r--r--dev-php/pecl-uploadprogress/Manifest4
-rw-r--r--dev-php/pecl-uploadprogress/files/1.0.3.1-php7.patch148
-rw-r--r--dev-php/pecl-uploadprogress/metadata.xml11
-rw-r--r--dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r4.ebuild22
4 files changed, 185 insertions, 0 deletions
diff --git a/dev-php/pecl-uploadprogress/Manifest b/dev-php/pecl-uploadprogress/Manifest
new file mode 100644
index 000000000000..878b07617bb2
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.3.1-php7.patch 4948 BLAKE2B 12ee139944a17989429e696e7457a3926d18f4300bf5bc2f9bfab2a036be88a47ea03ca64f06e378bb2811fdaba390e29a905eae87362c4a979c17407de53f3c SHA512 5b913ac4c006cee917ddb7140dd2e34dee6da9fac11001e6ee9f41ac0b65e3caa493c81612b05ef8ff99fec9c9a4cd4a2c2c275fc6124223d04648d43cae4fe4
+DIST uploadprogress-1.0.3.1.tgz 9040 BLAKE2B b926ee0cc7d40276425ea8eed86c5934c35ff2436b5785888394927a145620caa335d4eae87fd85bd754f8a67c1562f3b8d23a2c626f0d0ca4bed4bf4872e465 SHA512 c317a30ed81430184b643e2755867cdccf9848312aa31a5527e4fe229ac19ee3099121de8e253207b55dd7e788c28720bd3c477663c4ca15100478647a6dc1bb
+EBUILD pecl-uploadprogress-1.0.3.1-r4.ebuild 563 BLAKE2B fcc84e59b3228d4b94707e58bf56c1fdc9e189ce8b314fd2c4f80fc8dd1d8d5d4dab978ad94570c31f92713f281146c4057e07c45f9f01819da222dc26039294 SHA512 e9aa81d47e2d1b5e253bf2aea06f0989ee429e11df963115f34f1c8d2ced49ff9c6e7ba6d4fd0534965a447ecb6f9fd0b62235621b67a047a73cfe4185c2d4e0
+MISC metadata.xml 526 BLAKE2B 719015d4f11e9af4765f71ca1b8706fdf93c214ac7390f72579068151adebe0c39a29019201323aff6668ca2c7b31daeab247a867262138358a29034238a875a SHA512 18d72c569825f9dfd79a69d4ad1bc824f99001f2b1545aaaf6777a67050d9812dd81737c9e74bc9520aa5b375db4d94c5219f359eeaa5c8d7ae0a6437c96ec56
diff --git a/dev-php/pecl-uploadprogress/files/1.0.3.1-php7.patch b/dev-php/pecl-uploadprogress/files/1.0.3.1-php7.patch
new file mode 100644
index 000000000000..c90f4bd9539f
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/files/1.0.3.1-php7.patch
@@ -0,0 +1,148 @@
+From 7a4d6b3ac3575caedf9429940f54688411cbf5e9 Mon Sep 17 00:00:00 2001
+From: Jan-E <github@ehrhardt.nl>
+Date: Sun, 19 Apr 2015 18:49:48 +0200
+Subject: [PATCH 1/2] PHP7 compatibility
+
+---
+ uploadprogress.c | 36 +++++++++++++++++++++++++++++++++---
+ 1 file changed, 33 insertions(+), 3 deletions(-)
+
+diff --git a/uploadprogress.c b/uploadprogress.c
+index 30f6758..7a52ba7 100644
+--- a/uploadprogress.c
++++ b/uploadprogress.c
+@@ -71,7 +71,7 @@ PHPAPI extern int (*php_rfc1867_callback)(unsigned int , void *, void ** TSRMLS_
+ */
+ static int uploadprogress_php_rfc1867_file(unsigned int event, void *event_data, void **data TSRMLS_DC)
+ {
+- zval handler;
++ //zval handler;
+ char *callable = NULL;
+ uploadprogress_data * progress;
+ int read_bytes;
+@@ -157,7 +157,11 @@ static int uploadprogress_php_rfc1867_file(unsigned int event, void *event_data
+
+ if (get_contents) {
+ php_stream *stream;
++#if defined(ZEND_ENGINE_3)
++ int options = 0;
++#else
+ int options = ENFORCE_SAFE_MODE;
++#endif
+
+ stream = php_stream_open_wrapper(progress->data_filename, "ab", options, NULL);
+ if (stream) {
+@@ -301,7 +305,7 @@ PHP_FUNCTION(uploadprogress_get_info)
+ {
+ char * id;
+ int id_lg;
+- char method;
++ //char method;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s", &id, &id_lg) == FAILURE) {
+ return;
+@@ -417,7 +421,11 @@ static void uploadprogress_file_php_get_info(char * id, zval * return_value)
+ v[index] = 0;
+ }
+ }
++#if defined(ZEND_ENGINE_3)
++ add_assoc_string( return_value, k, v );
++#else
+ add_assoc_string( return_value, k, v, 1 );
++#endif
+ }
+ fclose(F);
+ }
+@@ -432,10 +440,22 @@ static void uploadprogress_file_php_get_info(char * id, zval * return_value)
+ */
+ static void uploadprogress_file_php_get_contents(char *id, char *fieldname, long maxlen, zval *return_value)
+ {
++#if defined(ZEND_ENGINE_3)
++ char *filename, *template, *data_identifier;
++ zend_string *contents;
++#else
+ char *filename, *template, *contents, *data_identifier;
++#endif
+ php_stream *stream;
++#if defined(ZEND_ENGINE_3)
++ int options = 0;
++#else
+ int options = ENFORCE_SAFE_MODE;
+- int len, newlen;
++#endif
++ int len;
++#if PHP_API_VERSION < 20100412
++ int newlen;
++#endif
+ TSRMLS_FETCH();
+
+ template = INI_STR("uploadprogress.file.contents_template");
+@@ -455,7 +475,13 @@ static void uploadprogress_file_php_get_contents(char *id, char *fieldname, long
+ }
+
+ /* uses mmap if possible */
++#if defined(ZEND_ENGINE_3)
++ contents = php_stream_copy_to_mem(stream, maxlen, 0);
++ len = contents->len;
++ if (contents && len > 0) {
++#else
+ if ((len = php_stream_copy_to_mem(stream, &contents, maxlen, 0)) > 0) {
++#endif
+
+ #if PHP_API_VERSION < 20100412
+ if (PG(magic_quotes_runtime)) {
+@@ -463,7 +489,11 @@ static void uploadprogress_file_php_get_contents(char *id, char *fieldname, long
+ len = newlen;
+ }
+ #endif
++#if defined(ZEND_ENGINE_3)
++ RETVAL_STR(contents);
++#else
+ RETVAL_STRINGL(contents, len, 0);
++#endif
+ } else if (len == 0) {
+ RETVAL_EMPTY_STRING();
+ } else {
+--
+2.1.4
+
+
+From 95d8a0fd4554e10c215d3ab301e901bd8f99c5d9 Mon Sep 17 00:00:00 2001
+From: Jan-E <github@ehrhardt.nl>
+Date: Mon, 20 Apr 2015 22:20:40 +0200
+Subject: [PATCH 2/2] int id_lg should be size_t id_lg
+
+---
+ uploadprogress.c | 4 ++++
+ 1 file changed, 4 insertions(+)
+
+diff --git a/uploadprogress.c b/uploadprogress.c
+index 7a52ba7..3d73d15 100644
+--- a/uploadprogress.c
++++ b/uploadprogress.c
+@@ -304,7 +304,11 @@ PHP_MINFO_FUNCTION(uploadprogress)
+ PHP_FUNCTION(uploadprogress_get_info)
+ {
+ char * id;
++#if defined(ZEND_ENGINE_3)
++ size_t id_lg;
++#else
+ int id_lg;
++#endif
+ //char method;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s", &id, &id_lg) == FAILURE) {
+--
+2.1.4
+
+--- a/uploadprogress.c 2011-08-15 09:21:10.000000000 -0400
++++ b/uploadprogress.c 2016-12-07 11:05:47.961377088 -0500
+@@ -213,7 +213,7 @@
+ FILE *F;
+ F = VCWD_FOPEN(progress->identifier_tmp, "wb");
+ if (F) {
+- fprintf(F, "upload_id=%s\nfieldname=%s\nfilename=%s\ntime_start=%d\ntime_last=%d\nspeed_average=%d\nspeed_last=%d\nbytes_uploaded=%d\nbytes_total=%d\nfiles_uploaded=%d\nest_sec=%d\n",
++ fprintf(F, "upload_id=%s\nfieldname=%s\nfilename=%s\ntime_start=%ld\ntime_last=%ld\nspeed_average=%d\nspeed_last=%d\nbytes_uploaded=%ld\nbytes_total=%ld\nfiles_uploaded=%d\nest_sec=%d\n",
+ progress->upload_id, progress->fieldname, progress->filename,
+ progress->time_start, progress->time_last,
+ progress->speed_average, progress->speed_last,
diff --git a/dev-php/pecl-uploadprogress/metadata.xml b/dev-php/pecl-uploadprogress/metadata.xml
new file mode 100644
index 000000000000..5f21917bcc4e
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+</maintainer>
+<longdescription lang="en">An extension to track progress of a file upload.
+See http://cvs.php.net/viewvc.cgi/pecl/uploadprogress/examples/ for a little example. It is only known to work on Apache with mod_php, other SAPI implementations unfortunately still have issues.
+</longdescription>
+</pkgmetadata>
diff --git a/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r4.ebuild b/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r4.ebuild
new file mode 100644
index 000000000000..062036ebd698
--- /dev/null
+++ b/dev-php/pecl-uploadprogress/pecl-uploadprogress-1.0.3.1-r4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+USE_PHP="php5-6 php7-0 php7-1 php7-2"
+
+inherit php-ext-pecl-r3
+
+DESCRIPTION="An extension to track progress of a file upload"
+LICENSE="PHP-3.01"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ php_targets_php5-6? ( dev-lang/php:5.6[apache2] )
+ php_targets_php7-0? ( dev-lang/php:7.0[apache2] )
+ php_targets_php7-1? ( dev-lang/php:7.1[apache2] )
+ php_targets_php7-2? ( dev-lang/php:7.2[apache2] )
+"
+PATCHES=( "${FILESDIR}/1.0.3.1-php7.patch" )