summaryrefslogtreecommitdiff
path: root/dev-php/pecl-svn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-php/pecl-svn
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-php/pecl-svn')
-rw-r--r--dev-php/pecl-svn/Manifest4
-rw-r--r--dev-php/pecl-svn/files/1.0.3-c99-fixes.patch68
-rw-r--r--dev-php/pecl-svn/metadata.xml8
-rw-r--r--dev-php/pecl-svn/pecl-svn-1.0.3-r1.ebuild22
4 files changed, 102 insertions, 0 deletions
diff --git a/dev-php/pecl-svn/Manifest b/dev-php/pecl-svn/Manifest
new file mode 100644
index 000000000000..a1dd8fa1d17e
--- /dev/null
+++ b/dev-php/pecl-svn/Manifest
@@ -0,0 +1,4 @@
+AUX 1.0.3-c99-fixes.patch 2241 BLAKE2B 8371def71451c0234b533bba30b3990441b95a7d0ab3de36548c71f452d5badd3a49905d64fe5267b66b087f9422a95f2846f862fb81304eba626898629a5142 SHA512 817048816e43f62246a172164691f95d9b84cc18fde096ed7ff9ce115e36b41942b22915dc149a9cbc972923d8f5f828e6197cc00503d7bca21bbb9bbba3c740
+DIST svn-1.0.3.tgz 27216 BLAKE2B 906f11dbc048f3bc7fa2b27c19661ce40c3008b35344cd0446c88432e2a6423ab6aeb396ded7723f70229767238d8a10eed6f8cd4ae29e73497eee6c5a0ac0a9 SHA512 41f111c3a47f66317c47318162bfd17c22ffef6462ababdafd9ed38220b1135464e52a365fbc206fd510dafad739437174faf1d0dd144707fad62da43c6c1a79
+EBUILD pecl-svn-1.0.3-r1.ebuild 407 BLAKE2B 2ca9546708eef06339f67bd9f7108bf332fb2fd8676052bcfc32cb2550149a3089a01be3670f9bfb33f64ec48b571efa5649253fe7e06f8e1d484f45ec02de0a SHA512 e6ad7b64b58704364e1efbd6af381bc46551239912a66cba0a4da98a064f8170d283c3c6fa7c23f8967c1e149a4340ebf041c4d66f48bb95f420ca7ed957fafe
+MISC metadata.xml 235 BLAKE2B 5b10304feea18aae1822be7d29bcce06c8715193b14a3dd2c4d79eb75e2767670352e2ca11e06b9a10ec04b63020a18254cd167e6d6be9072f4a200ca5d11ec4 SHA512 0b3e95bbf68eddf74289dad50f8828cffce2d904ff6f9bd5468177de979677cac11da84d1e0302c52b72085915b9d1b3496107172e5726520d51dad1981daf64
diff --git a/dev-php/pecl-svn/files/1.0.3-c99-fixes.patch b/dev-php/pecl-svn/files/1.0.3-c99-fixes.patch
new file mode 100644
index 000000000000..a1214ffd0cbe
--- /dev/null
+++ b/dev-php/pecl-svn/files/1.0.3-c99-fixes.patch
@@ -0,0 +1,68 @@
+--- a/svn.c 2016/05/04 04:14:33 339123
++++ b/svn.c 2016/05/04 07:32:45 339129
+@@ -977,6 +977,7 @@
+ apr_pool_t *subpool;
+ svn_opt_revision_t peg_revision;
+ const char *true_path;
++ apr_hash_index_t *hi;
+
+ if (zend_parse_parameters(ZEND_NUM_ARGS() TSRMLS_CC, "s|lbb",
+ &repos_url, &repos_url_len, &revision.value.number, &recurse, &peg) == FAILURE) {
+@@ -1021,7 +1022,7 @@
+
+ array_init(return_value);
+
+- for (apr_hash_index_t *hi = apr_hash_first(subpool, dirents); hi; hi = apr_hash_next(hi)) {
++ for (hi = apr_hash_first(subpool, dirents); hi; hi = apr_hash_next(hi)) {
+ const char *utf8_entryname;
+ svn_dirent_t *dirent;
+ apr_time_t now = apr_time_now();
+@@ -1031,9 +1032,10 @@
+ char timestr[20];
+ const char *utf8_timestr;
+ zval *row;
++ const char *key;
+
+- svn_utf_cstring_to_utf8 (&utf8_entryname, apr_hash_this_key(hi), subpool);
+- dirent = apr_hash_this_val(hi);
++ apr_hash_this(hi, &key, NULL, &dirent);
++ svn_utf_cstring_to_utf8 (&utf8_entryname, key, subpool);
+
+ /* svn_time_to_human_cstring gives us something *way* too long
+ to use for this, so we have to roll our own. We include
+@@ -1101,6 +1103,7 @@
+ {
+ struct php_svn_log_receiver_baton *baton = (struct php_svn_log_receiver_baton*) ibaton;
+ zval *row, *paths;
++ apr_hash_index_t *hi;
+ TSRMLS_FETCH();
+
+ if (rev == 0) {
+@@ -1127,7 +1130,7 @@
+ MAKE_STD_ZVAL(paths);
+ array_init(paths);
+
+- for (apr_hash_index_t *hi = apr_hash_first(pool, changed_paths); hi; hi = apr_hash_next(hi)) {
++ for (hi = apr_hash_first(pool, changed_paths); hi; hi = apr_hash_next(hi)) {
+ svn_log_changed_path_t *log_item;
+ zval *zpaths;
+ const char *path;
+@@ -1135,8 +1138,7 @@
+ MAKE_STD_ZVAL(zpaths);
+ array_init(zpaths);
+
+- path = apr_hash_this_key(hi);
+- log_item = apr_hash_this_val(hi);
++ apr_hash_this(hi, &path, NULL, &log_item);
+
+ add_assoc_stringl(zpaths, "action", &(log_item->action), 1,1);
+ add_assoc_string(zpaths, "path", path, 1);
+@@ -1152,7 +1154,7 @@
+ add_assoc_zval(paths, path, zpaths);
+ }
+
+- zend_hash_sort(Z_ARRVAL_P(paths), zend_qsort, compare_keys_as_paths, 1);
++ zend_hash_sort(Z_ARRVAL_P(paths), zend_qsort, compare_keys_as_paths, 1 TSRMLS_CC);
+ add_assoc_zval(row,"paths",paths);
+ }
+
diff --git a/dev-php/pecl-svn/metadata.xml b/dev-php/pecl-svn/metadata.xml
new file mode 100644
index 000000000000..aca42932b833
--- /dev/null
+++ b/dev-php/pecl-svn/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>php-bugs@gentoo.org</email>
+ <name>PHP</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-php/pecl-svn/pecl-svn-1.0.3-r1.ebuild b/dev-php/pecl-svn/pecl-svn-1.0.3-r1.ebuild
new file mode 100644
index 000000000000..52eb35c8875d
--- /dev/null
+++ b/dev-php/pecl-svn/pecl-svn-1.0.3-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PHP_EXT_NAME="svn"
+
+USE_PHP="php5-6"
+
+inherit php-ext-pecl-r3
+
+KEYWORDS="~amd64 ~x86"
+
+DESCRIPTION="PHP Bindings for the Subversion Revision control system"
+LICENSE="PHP-3.01"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-vcs/subversion"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/1.0.3-c99-fixes.patch" )